Bug 432574 - clean_ids breaks xref to listitem
Summary: clean_ids breaks xref to listitem
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Publican
Classification: Community
Component: publican   
(Show other bugs)
Version: 2.0
Hardware: All
OS: Linux
high
urgent
Target Milestone: ---
Assignee: Jeff Fearn ๐Ÿž
QA Contact: Michael Hideo
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-13 00:25 UTC by Jeff Fearn ๐Ÿž
Modified: 2010-11-24 03:59 UTC (History)
2 users (show)

Fixed In Version: 0.30
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 01:51:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Fearn ๐Ÿž 2008-02-13 00:25:11 UTC
Description of problem:
When an xref refers to a listitem running clean_ids will null the listitem id
and leave an empty xref target, resulting in invalid DocBook.

Version-Release number of selected component (if applicable):
All.

How reproducible:
100%

Steps to Reproduce:
1. Create a list containing a listitem with an id
2. Create an xref refereing to the above id
3. make clean_ids
  
Actual results:
... element xref: validity error : IDREF attribute endterm references an unknown
ID "..."

Expected results:
no error.

Additional info:
It is valid to have xrefs to listitems, since listitems do not have titles
xmlClean should not change listitem ids.


Note You need to log in before you can comment on or make changes to this bug.