Bug 432575 - Kernel immediately crashes without acpi=off on ATI RS690
Kernel immediately crashes without acpi=off on ATI RS690
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 19:34 EST by Paul Henshall
Modified: 2008-02-17 09:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 09:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Henshall 2008-02-12 19:34:41 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021019 Fedora/3.0b4pre-0.beta2.18.nightly20080210.fc9 Minefield/3.0b4pre

Description of problem:
With all 2.6.24 series kernels I have tried, the kernel immediately oopses with lots of mention of acpi functions unless I have acpi=off.
Current kernel version then fails later on with an rt2500pci oops, after another warning when starting the avahi service if acpi=off, earlier kernels would at least boot.
Unfortunately it is not possible to capture useful oops information, as it happens very early, so if you attempt to use a fb all you get is a black screen.


Version-Release number of selected component (if applicable):
kernel-2.6.24.1-31

How reproducible:
Always


Steps to Reproduce:
1. Boot without acpi=off
2. Immediate oops
3.

Actual Results:
oops with seemingly infinite trace

Expected Results:
Normal boot

Additional info:
2.6.23 from fedora 8 works.
Comment 1 mohamed 2008-02-15 15:24:59 EST
I've got the same prob;em but on fedora 8 64bit.

If i don't specify acpi=off or irqpoll, it freezes like you mentioned.  All in
all this is very random, as sometimes i can boot and sometimes i cant without
specifying the options.

i've detailed my problem in here
(http://forums.fedoraforum.org/forum/showthread.php?t=173700).

In summary i can SOMETIMES boot without acpi=off || irqpoll, sometimes the NIC
doesn't work. I am pretty sure that my NIC isn't busted either becaused if i
boot into vista straight after to check it automatically logs onto the net.

My exact hardware specs are;

Samsung SpinPoint T 500GB SATA-II 16MB Cache - OEM (HD501LJ
Samsung SpinPoint T 320GB SATA-II 16MB Cache - OEM (HD321KJ)
Corsair HX 520W ATX2.2 Modular SLI Compliant PSU (CMPSU-520HXUK)
Corsair 4GB DDR2 XMS2 PC2-6400C5 TwinX (2x2GB)
Intel Core 2 Quad Pro Q6600 "Energy Efficient SLACR 95W Edition" 2.40GHz
(1066FSB) - Retail
EVGA GeForce 8800 GTS "Crysis Edition" 512MB GDDR3 HDTV/Dual DVI (PCI-Express) -
Retail (512-P3-E841-AE-CrysisUK)
Thermalright Ultra-120 Extreme CPU Cooler (Socket AM2/LGA775)
Samsung SH-S203NRSMN 20x DVD±RW SATA Dual Layer Lightscribe ReWriter
(Beige/Black/Silver) - Retail
Abit IP35 (Socket 775) PCI-Express DDR2 Motherboard
Antec Solo Quiet Mini Tower Case - No PSU
Dell 22 inch Widescreen Flat Panel Display with built-in Webcam (SP2208WFP)
Auzentech X-Plosion DTS Connect 7.1 Sound Card – Retail 


Just for reference, the same thing happens in ubuntu but if i boot with acpi=off
and irqpoll the sound card is always detected unlike fedora where it's detected
only somtimes.  I hope this gets fixed before fedora 9.

Kernel no; 2.6.23.15-137.fc8.  I done a full system update about a day ago.


thanks for your time.
Comment 2 Paul Henshall 2008-02-17 09:27:47 EST
I can confirm that the updated kernel kernel-2.6.25-0.40.rc1.git2 fails to boot
for a different reason (related to rt2x00pci).

Note You need to log in before you can comment on or make changes to this bug.