Bug 432582 - %config(noreplace) /var/yp/Makefile
%config(noreplace) /var/yp/Makefile
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ypserv (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-12 23:47 EST by Ralf Corsepius
Modified: 2008-02-28 16:41 EST (History)
0 users

See Also:
Fixed In Version: 2.19-9.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 16:41:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-02-12 23:47:41 EST
Description of problem:

Inside of the spec-file
/var/yp/Makefile should be marked as
%config(noreplace)

Rationale: /var/yp/Makefile is supposed to be edited and customized.
Due to it not being marked %config(noreplace), ypserv package updates will blow
away all customizations users might have applied. As a result ypservers might
become unusable and kill whole networks.

Version-Release number of selected component (if applicable):
ypserv-2.19-8.fc8

How reproducible:
Always.

Steps to Reproduce:
1. edit /var/yp/Makefile
2. rpm -U ypserv-<newversion>.rpm
  
Actual results:
The edited /var/yp/Makefile is being backed up to /var/yp/Makefile.rpmsave and
replaced with the rpm's original /var/yp/Makefile. All customizations are being
lost. The next "make" will create ypserver dbs not meeting the user's
expectations, which are likely to break yp-based networks (As in my case).
Comment 1 Fedora Update System 2008-02-13 08:59:52 EST
ypserv-2.19-9.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-02-15 21:15:10 EST
ypserv-2.19-9.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ypserv'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1726
Comment 3 Fedora Update System 2008-02-28 16:40:58 EST
ypserv-2.19-9.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.