Bug 432590 - Error in I830WaitLpRing(). DRIUnlock called when not locked
Error in I830WaitLpRing(). DRIUnlock called when not locked
Status: CLOSED DUPLICATE of bug 431340
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 01:25 EST by Ilya Ryabinkin
Modified: 2008-02-13 05:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 05:56:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.log (61.38 KB, text/plain)
2008-02-13 01:25 EST, Ilya Ryabinkin
no flags Details
Xorg.conf (3.25 KB, application/octet-stream)
2008-02-13 01:27 EST, Ilya Ryabinkin
no flags Details

  None (edit)
Description Ilya Ryabinkin 2008-02-13 01:25:49 EST
Description of problem:

The problem appeared today morning. When my laptop was coming out of hibernate,
I've read a message telling me that Xorg is crashed. Yesterday I've upgraded
kernel to 2.6.23.15-80.fc7.

Starting xorg manually does not help, reboot need.

The end of xorg.log contains following lines:

 Error in I830WaitLpRing(), now is 291029966, start is 291027965
pgetbl_ctl: 0x1ffc0001 pgetbl_err: 0x0
ipeir: 0 iphdr: c000720
LP ring tail: 0 head: 8 len: 1f001 start 0
eir: 0 esr: 0 emr: ffff
instdone: ffc1 instpm: 0
memmode: 108 instps: 800784cc
hwstam: fffe ier: 22 imr: 8 iir: 10
space: 0 wanted 8
DRIUnlock called when not locked
(II) I810(0): [drm] removed 1 reserved context for kernel
(II) I810(0): [drm] unmapping 8192 bytes of SAREA 0xe0320000 at 0xb7f08000

Fatal server error:
lockup

(WW) I810(0): Successfully set original devices
(II) I810(0): xf86UnbindGARTMemory: unbind key 8
(II) I810(0): xf86UnbindGARTMemory: unbind key 0
(II) I810(0): xf86UnbindGARTMemory: unbind key 1
(II) I810(0): xf86UnbindGARTMemory: unbind key 3
(II) I810(0): xf86UnbindGARTMemory: unbind key 2
(II) I810(0): xf86UnbindGARTMemory: unbind key 4
(II) I810(0): xf86UnbindGARTMemory: unbind key 5
(II) I810(0): xf86UnbindGARTMemory: unbind key 6
(II) I810(0): xf86UnbindGARTMemory: unbind key 7
(WW) I810(0): Successfully set original devices (2)


Version-Release number of selected component (if applicable):
xorg-x11-drv-i810-2.0.0-4.fc7
kernel-2.6.23.15-80.fc7
xorg-x11-server-Xorg-1.3.0.0-16.fc7

How reproducible:
Does not tested
Steps to Reproduce:
1. hibernate computer
2. resume computer
3. see crash
  
Actual results:
Xorg crash

Expected results:
No crashes are expected

Additional info:
Comment 1 Ilya Ryabinkin 2008-02-13 01:25:49 EST
Created attachment 294754 [details]
Xorg.log
Comment 2 Ilya Ryabinkin 2008-02-13 01:27:42 EST
Created attachment 294755 [details]
Xorg.conf
Comment 3 Ilya Ryabinkin 2008-02-13 02:02:09 EST
Hardware details:

Dell Latitude D610 laptop with Intel 915 integrated video. I've many troubles
with it, it was quite difficult to fine appropriate parameters in xorg.conf to
function properly. 
Comment 4 Matěj Cepl 2008-02-13 05:56:31 EST

*** This bug has been marked as a duplicate of 431340 ***

Note You need to log in before you can comment on or make changes to this bug.