Bug 4326 - arp2ethers script in arpwatch package has a typo
Summary: arp2ethers script in arpwatch package has a typo
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tcpdump   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-03 04:38 UTC by Pekka Savola
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-04 13:23:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 1999-08-03 04:38:44 UTC
There wasn't arpwatch package in the list, so I put it
to tcpdump..

RH6.0 arpwatch package's arp2ethers script seems to be
broken; it just prints the usage of awk here.  This seemed
to fix it:

--- arp2ethers  Mon Mar 22 07:15:36 1999
+++ arp2ethers_ Tue Aug  3 07:29:01 1999
@@ -14,7 +14,7 @@
 #

 sort +2rn arp.dat | \
-    awk -e 'NF == 4 { print }' | \
+    awk 'NF == 4 { print }' | \
     awk -f p.awk | \
     egrep -v '\.[0-9][0-9]*$' | \
     sed -e 's/ .*      /       /' | \

Comment 1 Jeff Johnson 1999-08-04 13:23:59 UTC
Fixed in tcpdump-3.4-11. Thanks for the patch.


Note You need to log in before you can comment on or make changes to this bug.