Bug 432609 - Unticking virtualisation makes server unbootable
Unticking virtualisation makes server unbootable
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pirut (Show other bugs)
5.3
All Linux
low Severity high
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 06:20 EST by Robert Donkin
Modified: 2013-03-12 16:05 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-12 16:05:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Donkin 2008-02-13 06:20:35 EST
Description of problem:
This was one of those moment where I thought before I did it: RedHat can't be
that stupid as to uninstall all kernels with a single click then apply rendering
the system unbootable followed by RedHat's recovered tools can't be so lame as
to refuse to reinstall the boot loader since the system has had it's kernel
removed. More fool me. I think had the pleasure of experiencing first hand
RedHat recovery tools. So, it's clean reintallation time now.

Version-Release number of selected component (if applicable):


How reproducible:
Cripples RHEL every time

Steps to Reproduce:
1. Choose Add/Remove Software
2. Untick virtualisation
3. Click Apply
  
Actual results:
All kernals are removed from the boot loaded and a special entry called 'Other'
entered into grub.conf. Upon reboot, the absence of a kernel means that the
server will not start.

Expected results:
Something reasonable (for example, don't remove the last kernel from /boot, a
warning or when virtualisation is unticked installing a vanilla kernel).

Additional info:
Comment 1 James Antill 2013-03-12 16:05:44 EDT
The way groups work has changed a lot of RHEL-6 (and we can warn about removing certain packages), and is going to change even more for RHEL-7. Alas. we can't easily backport this work.


This request was evaluated by Red Hat Engineering for inclusion in a Red 
Hat Enterprise Linux maintenance release.

Red Hat does not currently plan to provide this change in a Red Hat 
Enterprise Linux update release for currently deployed products.

With the goal of minimizing risk of change for deployed systems, and in 
response to customer and partner requirements, Red Hat takes a 
conservative approach when evaluating enhancements for inclusion in 
maintenance updates for currently deployed products. The primary 
objectives of update releases are to enable new hardware platform 
support and to resolve critical defects.

Note You need to log in before you can comment on or make changes to this bug.