Bug 432615 - host|nslookup et. al. cannot see names in .org domain
host|nslookup et. al. cannot see names in .org domain
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
8
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 07:27 EST by Robert Bogomip
Modified: 2013-04-30 19:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-14 04:46:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Bogomip 2008-02-13 07:27:58 EST
Description of problem:

Bind associated utils cannot resolve names in the.org domain

Version-Release number of selected component (if applicable):

$ rpm -qa 'bind*'
bind-utils-9.5.0-23.b1.fc8.x86_64
bind-libs-9.5.0-23.b1.fc8.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Get list of .org nameservers

  $ host -t ns org.
  org name server tld1.ultradns.net.
  org name server c0.org.afilias-nst.info.
  org name server b0.org.afilias-nst.org.
  org name server tld2.ultradns.net.
  org name server a0.org.afilias-nst.info.
  org name server d0.org.afilias-nst.org.

2. Ask one of these servers for a well known domain's nameservers

  $ host -t ns sourceforge.org. tld1.ultradns.net.
  Using domain server:
  Name: tld1.ultradns.net.
  Address: 204.74.112.1#53
  Aliases:

  sourceforge.org has no NS record

Urk!

Actual results:


Expected results:

  $ host -t ns com.
  com name server l.gtld-servers.net.
  com name server g.gtld-servers.net.
  .
  .
  .
  $ host -t ns microsoft.com. g.gtld-servers.net.
  Using domain server:
  Name: g.gtld-servers.net.
  Address: 192.42.93.30#53
  Aliases:

  microsoft.com name server ns1.msft.net.
  microsoft.com name server ns2.msft.net.
  microsoft.com name server ns3.msft.net.
  microsoft.com name server ns4.msft.net.
  microsoft.com name server ns5.msft.net.

Additional info:

"host -v" reveals that the .org nameservers are giving out the requisite
information in the AUTHORITY section rather than the ANSWER section. 

  $ host -v -t ns sourceforge.org. tld1.ultradns.net.
  Trying "sourceforge.org"
  Using domain server:
  Name: tld1.ultradns.net.
  Address: 204.74.112.1#53
  Aliases:

  ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 52742
  ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 3, ADDITIONAL: 0

  ;; QUESTION SECTION:
  ;sourceforge.org. IN NS

  ;; AUTHORITY SECTION:
  sourceforge.org. 86400 IN NS ns3.ostg.com.
  sourceforge.org. 86400 IN NS ns2.ostg.com.
  sourceforge.org. 86400 IN NS ns1.ostg.com.

  Received 95 bytes from 204.74.112.1#53 in 18 ms

Is this a bug in bind-utils or the .org nameservers?
Comment 1 Robert Bogomip 2008-02-13 07:31:08 EST
I've just installed named and it seems that named itself does not suffer this bug.

  $ rpm -q bind
  bind-9.5.0-23.b1.fc8.x86_64
  $ host -t ns sourceforge.org. localhost.
  Using domain server:
  Name: localhost.
  Address: 127.0.0.1#53
  Aliases:

  sourceforge.org name server ns3.ostg.com.
  sourceforge.org name server ns1.ostg.com.
  sourceforge.org name server ns2.ostg.com.
Comment 2 Adam Tkac 2008-02-14 04:46:09 EST
Main problem is that com. nameservers are broken
(http://marc.info/?t=120291582900002&r=1&w=2) because they returns NS records in
answer section without AA flag so host utility simply use them. When you try
query "correct" servers (non-authoritative data is not returned in answer
section) and servers doesn't have recursion enabled this is intentional behavior
of host (discussed with upstream). Please use dig utility for such detailed
information. Thanks for your report, closing

Note You need to log in before you can comment on or make changes to this bug.