Bug 432644 - hal deamon segfault
hal deamon segfault
Status: CLOSED DUPLICATE of bug 431377
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
Depends On:
Blocks: 280251
  Show dependency treegraph
Reported: 2008-02-13 10:56 EST by Ivana Varekova
Modified: 2013-03-05 22:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-15 10:09:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
`hald --daemon=no --verbose=yes` output: (7.17 KB, text/plain)
2008-02-13 10:59 EST, Ivana Varekova
no flags Details

  None (edit)
Description Ivana Varekova 2008-02-13 10:56:46 EST
Description of problem:
hal daemon segfaults with specific rules. I'm trying to find the best rules for
pilot-link package - the rules i chose at the end are in fc8 cvs now. They seems
to be right for me - pilot-link is working with them but when they are initially
used after the upgrade to new pilot-link package they kill the hal-daemon. It
seems to me as a pilot-link bug. For now this issue blocks the release of fixed
pilot-link package.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.grab suitable package from
install it
try to sync a palm
Actual results:
hal daemon segfaults

Expected results:
hal daemon will be ok

Additional info:

The log from /var/log/messages file which is produced is:
Feb 13 13:53:29 caladan acpid: client connected from 23065[68:68]
Feb 13 13:54:27 caladan kernel: usb 5-1: USB disconnect, address 3
Feb 13 13:54:28 caladan kernel: usb 5-1: new full speed USB device using
uhci_hcd and address 4
Feb 13 13:54:28 caladan kernel: usb 5-1: configuration #1 chosen from 1 choice
Feb 13 13:54:29 caladan kernel: hald[23030]: segfault at b7dde000 eip 080571b6
esp bf937320 error 4

the output of `hald --daemon=no --verbose=yes` is attached in the next comment.
Comment 1 Ivana Varekova 2008-02-13 10:59:43 EST
Created attachment 294799 [details]
`hald --daemon=no --verbose=yes` output:
Comment 2 Ivana Varekova 2008-02-13 11:06:39 EST
Ops - sorry in the 0th comment there should be it seems to be hal bug :). 
The same bug does not appear if I use only a part of rules from *.fdi file from
koji build - but I have not find any system/reason for this behavior.
I can reproduce this bug myself - so I can test fixed version too.
Comment 3 Kevin R. Page 2008-02-14 05:45:03 EST
Duplicate of bug #431377
Comment 4 Matthias Clasen 2008-02-15 10:09:42 EST

*** This bug has been marked as a duplicate of 431377 ***

Note You need to log in before you can comment on or make changes to this bug.