Bug 432652 - RHEL5.2: Modify SATA IDE mode quirk
RHEL5.2: Modify SATA IDE mode quirk
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.2
All Linux
high Severity high
: rc
: ---
Assigned To: Bhavna Sarathy
Martin Jenner
:
Depends On:
Blocks: 253746 466422
  Show dependency treegraph
 
Reported: 2008-02-13 11:53 EST by Bhavna Sarathy
Modified: 2008-10-10 03:39 EDT (History)
11 users (show)

See Also:
Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed SATA IDE patch to fix resume issue (4.43 KB, patch)
2008-02-18 16:35 EST, Bhavna Sarathy
no flags Details | Diff
ahci driver side fix patch (833 bytes, patch)
2008-03-21 04:39 EDT, Richard Zhao
no flags Details | Diff

  None (edit)
Description Bhavna Sarathy 2008-02-13 11:53:42 EST
AMD chipset dev, team has been moving towards unifying SB600/700/800 support.
This patch was approved by Jeff Garzik and is necessary to initialize ans set
SATA mode correctly.

http://marc.info/?l=linux-pci&m=120193321032703&w=2
Comment 1 Bhavna Sarathy 2008-02-18 12:32:21 EST
This patch is a bug fix and will affect future SBs.

The bug is S3 resume failed when you put SATA disk 2nd port and set SATA
type as native IDE. The root cause is we have not correctly set
operating mode when resume. 

Is this sufficient to push it into R5.2?
Comment 2 Ronald Pacheco 2008-02-18 14:20:52 EST
We have an HP dx2450 with the SB700 that can be used for validation.
Comment 3 Peter Martuccelli 2008-02-18 14:29:06 EST
The system is in my office ready for testing.
Comment 4 Bhavna Sarathy 2008-02-18 16:35:45 EST
Created attachment 295210 [details]
Proposed SATA IDE patch to fix resume issue

The patch for RHEL5.2 will have to include the pci_fixups_resume and
resume_early implementation.   I've attached the backport I have come 
up with so far.
Comment 5 Bhavna Sarathy 2008-02-18 16:39:08 EST
Shane, 

Please look through this patch for completeness and provide the upstream patch 
set that adds the resume and resume_early implementation. Once I have the 
complete back port done I would ask you to test on RHEL5 as well.

Also, do we need resume_early and it's counterpart suspend_late?  Or does the 
latter have no bearing to the chipset resume issue?

Ideally we want the smallest patch set necessary to fix the issue.

Regards,
Bhavana
Comment 6 Bhavna Sarathy 2008-03-14 14:30:16 EDT
Russ, please add the master tracker.  Just when we thought we were done with R5.2...
Comment 7 Martin Jenner 2008-03-14 17:08:30 EDT
Need the usual bullet items answered for an exception request post beta kernel:

1) business justification
2) patch status, is patch upstream
3) the intended patch attached to the bz or a clear pointer to said
4) current testing status
5) test plan

QE Can't ack without this data.
Comment 8 Crane Cai 2008-03-16 21:04:38 EDT
Hi Bhavana,
This backport of PCI_RESUME_FIXUP is well.

(In reply to comment #5)
> Shane, 
> 
> Please look through this patch for completeness and provide the upstream patch 
> set that adds the resume and resume_early implementation. Once I have the 
> complete back port done I would ask you to test on RHEL5 as well.
> 
> Also, do we need resume_early and it's counterpart suspend_late?  Or does the 
> latter have no bearing to the chipset resume issue?
> 
> Ideally we want the smallest patch set necessary to fix the issue.
> 
> Regards,
> Bhavana

Comment 9 Shane Huang 2008-03-17 04:12:02 EDT
upstream commit:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-
2.6.git;a=commit;h=05a7d22b9f02e7fe8fb5ff972b46743948139b3c
Comment 10 Richard Zhao 2008-03-21 04:39:45 EDT
Created attachment 298778 [details]
ahci driver side fix patch

1) business justification
   We found the s3 resume failed issue exists in RHEL 5.2 beta. The patch is
for AMD SB600/SB700, which is already be seen in market. So it's very urgent
for us to have it be supported in RHEL5.2.

2) patch status, is patch upstream
   Upstream has accepted the patch, see Comment#9.

3) the intended patch attached to the bz or a clear pointer to said
   If we use the upstream patch, we needs back port pci_fixups_resume. But when
we back port it, we find it involve too much of power management subsystem
(resume_early). So I think it's better for redhat to back port
pci_fixups_resume.
   If pci_fixups_resume will not be back ported, we can also fix the issue on
ahci driver side. Please see the attached ahci driver side fix patch.

4) current testing status
   ahci driver side fix patch is under test by AMD QA, and will be finished in
next week.
5) test plan
   Do acpi test to check whether the issue is fixed.
Comment 11 Bhavna Sarathy 2008-03-21 11:09:39 EDT
Thanks Richard for the answering Martin's bulleted items.   

I want to clarify the patch that we want in RHEL5.2 a bit more.  We are
sensitive to the fact that R5.2 is post beta and want to make the least lines 
of change that would still fix the issue but not introduce a massive change.  
The upstream patch as is will need (as Richard described) resume early 
changes in the PM subsystems.  Instead we have chosen to use the existing 
AHCI resume function and adding the relevant code to that function. 

The brew build is being tested at AMD
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=1222747

The 32-bit test have completed with successful results.  The 64-bit test results
will be available Monday.  I will submit the patch to RHML after the 64-bit
results are in as well.

If there are any more questions please let us know.
Comment 12 Bhavna Sarathy 2008-03-24 15:28:40 EDT
Posted to RHML on Mar 24.
Comment 13 Bhavna Sarathy 2008-03-24 15:30:25 EDT
Both 32-bit and 64-bit test results are done and the brew build works for all
SATA ports, both native IDE and Legacy IDE.    Please provide the BZ ACKs.
Comment 17 Don Zickus 2008-04-02 12:09:14 EDT
in kernel-2.6.18-88.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 20 errata-xmlrpc 2008-05-21 11:09:26 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html

Note You need to log in before you can comment on or make changes to this bug.