Bug 432654 - Fresh install of OpenOffice on rawhide fails to start - access rights
Fresh install of OpenOffice on rawhide fails to start - access rights
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 11:55 EST by Robin Norwood
Modified: 2008-02-19 09:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 09:47:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 86080 None None None Never

  None (edit)
Description Robin Norwood 2008-02-13 11:55:03 EST
I didn't have openoffice installed on my rawhide box, and ran:

sudo yum install openoffice.org-writer

Yesterday to install it.

When I run it, I get the following dialog box:

The application cannot be started.
OpenOffice.org user installation could not be processed due to missing access
rights.  Please make sure that you have sufficient access rights for the
following locations and restart OpenOffice.org:

/home/rnorwood/.openoffice.org2.0


[rnorwood@solitude ~]$ ls -la .openoffice.org2.0/
total 24
drwxr-xr-x  3 root     root     4096 2008-02-12 11:34 ./
drwxrwxr-x 72 rnorwood rnorwood 4096 2008-02-13 10:41 ../
drwxr-xr-x  4 root     root     4096 2008-02-12 11:34 user/

So that directory was created with the wrong perms, at about the time I
installed oo-writer.

I was able to reproduce this by removing openoffice.org-* rpms, rm -rf
.openoffice.org2.0 (as root), and re-installing with yum.

chown-ing the directory to rnorwood.rnorwood fixes the problem also.
Comment 1 Caolan McNamara 2008-02-14 03:30:30 EST
ah damnit, got to be the stupid unopkg putting things in $HOME during rpm
installation, very not good
Comment 2 Caolan McNamara 2008-02-14 06:08:59 EST
Fix checked in, should be ok in >= 2.4.0-7.2
Comment 3 Robin Norwood 2008-02-14 12:12:48 EST
Dear java: please stay out of my homedir.

kthxbye.

(I'll check it out when 2.4.0-7-2 hits rawhide)

Note You need to log in before you can comment on or make changes to this bug.