Bug 432727 - EXT4-fs: dm-0: not marked to use ok with test-code
EXT4-fs: dm-0: not marked to use ok with test-code
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Eric Sandeen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-13 20:08 EST by Reindl Harald
Modified: 2008-02-28 09:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 09:31:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (vmware) (12.28 KB, image/png)
2008-02-13 20:08 EST, Reindl Harald
no flags Details

  None (edit)
Description Reindl Harald 2008-02-13 20:08:11 EST
Hi

See title and atatched screenshot
I tested ext4 with entry ext4dev in /etc/fstab
Since kernel 26.24.1-26.fc9 this problem exists

2.6.24-17.fc9 boots without troubles, but if i change back to etx3 new kernels
semmes to see the lvm as etx4 and the same problem, with changing back to ext3
the working kernel says fs is not ok, so the only way is mount rw, change back
to ext4dev and boot with the last working 2.6.24
Comment 1 Reindl Harald 2008-02-13 20:08:11 EST
Created attachment 294860 [details]
Screenshot (vmware)
Comment 2 Jon Stanley 2008-02-28 00:02:56 EST
running into this same issue - the last valid kernel that i have on the system
is 2.6.24-9.fc9 and it fails with kernel-2.6.25-0.65.rc2.git7.fc9.i686.  Just
like the reporter, this is under vmware.

The VM is available for tinkering, and since ext4 is my root, I obviously don't
care if it goes boom :).

Let me know if there's anything I can do to further this.
Comment 3 Eric Sandeen 2008-02-28 09:31:00 EST
this is actually not a bug.

You seem to be reporting 2 things, if I understand:

1) if you mount the fs as ext4dev it no longer mounts as ext3.  This is
expected; non-compatible flags get set.  If you really need to go back to ext3,
you can by mounting with -o noextents, finding all extent-based files, and
copying them to create old-format ext3 files.

2) the "not ok to use with test code" message when mounting ext4dev filesystems.
 Please search for "test_fs" on the page at http://fedoraproject.org/wiki/FedoraExt4

-Eric

Note You need to log in before you can comment on or make changes to this bug.