Bug 432738 - enhancement request: rsyslog-postgresql
Summary: enhancement request: rsyslog-postgresql
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-14 03:02 UTC by Fran Taylor
Modified: 2008-02-21 16:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 16:19:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SELinux policy change for rsyslog (182 bytes, text/plain)
2008-02-16 17:27 UTC, Fran Taylor
no flags Details

Description Fran Taylor 2008-02-14 03:02:27 UTC
rsyslog 2.0 supports postgresql

it would be very simple to add an rpm with postgres support

I am working on one but there are SELinux issues that I am still working on.

It would be very nice if this were an official package.

Comment 1 Peter Vrabec 2008-02-14 12:53:56 UTC
Hi Fran, this is nice coincidence I have just built rsyslog-2.0.2-1 with 
PostgresSQL support. :) Could you try it please.

Comment 2 Fran Taylor 2008-02-16 17:27:54 UTC
Created attachment 295077 [details]
SELinux policy change for rsyslog

Comment 3 Fran Taylor 2008-02-16 17:33:19 UTC
I have installed rsyslog-2.0.2-1 and it seems to be missing two items: the .sql
file necessary to initialize the database (contained in the distribution) and a
SELinux policy change to allow rsyslog to open a socket connection on the
postgres port (I think this is missing for the mysql version as well).  I have
attached my solution to the latter issue, I don't know how such things are
solved in general in these cases.


Comment 4 Fran Taylor 2008-02-17 06:31:11 UTC
I installed your package on my Fedora 8 machine, and it has slowed to a crawl
processing two SELinux failure messages:

SELinux prevented rsyslogd from rerading from the urandom device.
SELinux is preventing rsyslogd (syslogd_t) "getattr" to /etc/krb5.conf
(krb5_conf_t).

My rsyslog-postgresql doesn't have these problems.  To make it, I just copied
and pasted stuff in the spec file in the obvious manner.  With the addition of
the SELinux policy change I attached, it works fine. 


Comment 5 Peter Vrabec 2008-02-18 12:50:52 UTC
thnx. Fran, 
.sql file - will be fixed in next release,
selinux policy - I'm gonna contact dwalsh@redhat.com,
but I can't reproduce selinux problem from comment #4. rsyslog is built 
without GSSAPI support, so it shouldn't do anything with krb5.conf.

Comment 6 Daniel Walsh 2008-02-18 14:28:25 UTC
Fixed in selinux-policy-3.2.8-1.fc9

Also added 

	postgresql_stream_connect(syslogd_t)

So you could set it up without using network.


Note You need to log in before you can comment on or make changes to this bug.