Bug 432744 - fix atlas infinite loop during configure
fix atlas infinite loop during configure
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: atlas (Show other bugs)
9
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Quentin Spencer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2008-02-13 23:16 EST by Doug Chapman
Modified: 2008-07-26 01:56 EDT (History)
0 users

See Also:
Fixed In Version: 3.6.0-15.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 18:24:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
set default answer for ia64 to Itanium2 (603 bytes, patch)
2008-02-13 23:18 EST, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2008-02-13 23:16:29 EST
Description of problem:
When trying to build atlas on ia64 we hit an infinite loop during configure:

Enter your machine type:
   1. IA-64 Itanium 1
   2. IA-64 Itanium 2
   3. Other/UNKNOWN
Enter machine number [3]: ^J
3 larger than max value of 2.  Try again.

Enter machine number [3]: ^J
3 larger than max value of 2.  Try again.

(continues forever)

The problem is all other archs have the default being the most common variant of
the processor.  With Itanium the default is UNKNOWN which just asks again.  The
default here should be Itanium 2.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2008-02-13 23:18:34 EST
Created attachment 294886 [details]
set default answer for ia64 to Itanium2
Comment 2 Fedora Update System 2008-05-07 13:28:41 EDT
atlas-3.6.0-15.fc9 has been submitted as an update for Fedora 9
Comment 3 Fedora Update System 2008-05-13 11:30:05 EDT
atlas-3.6.0-15.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update atlas'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-3619
Comment 4 Bug Zapper 2008-05-14 01:11:21 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Fedora Update System 2008-05-17 18:24:21 EDT
atlas-3.6.0-15.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2008-07-26 01:56:53 EDT
atlas-3.6.0-15.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.