This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 432770 - Lenovo X61 some USB ports not working
Lenovo X61 some USB ports not working
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
i386 Linux
high Severity high
: rc
: ---
Assigned To: Pete Zaitcev
Martin Jenner
:
Depends On:
Blocks: KernelPrio5.3
  Show dependency treegraph
 
Reported: 2008-02-14 04:52 EST by Jan Wildeboer
Modified: 2008-08-19 15:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-19 15:37:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
DMESG after reboot (25.31 KB, text/plain)
2008-03-01 03:10 EST, Jan Wildeboer
no flags Details
clean dmesg of -83 32bit kernel on X61 (25.49 KB, text/plain)
2008-03-07 05:26 EST, Jan Wildeboer
no flags Details

  None (edit)
Description Jan Wildeboer 2008-02-14 04:52:23 EST
Description of problem:

The X61 has three USB Ports. One left of keyboard, which works fine. Two right
of keyboard which do not work as expected.

Version-Release number of selected component (if applicable):

Current RHEL 5.1

How reproducible:

Always

Steps to Reproduce:
1. Connect USB device to one of the ports on the right side
2. Check /var/log/messages
3. USB device does not work
  
Actual results:

USB errors

Expected results:

Working USB device

Additional info:

Here some excerpts when connecting a CD drive:

Working port:

Feb 14 10:46:24 jhwx61 kernel: usb 5-3: new high speed USB device using ehci_hcd
and address 6
Feb 14 10:46:24 jhwx61 kernel: usb 5-3: configuration #1 chosen from 1 choice
Feb 14 10:46:24 jhwx61 kernel: scsi3 : SCSI emulation for USB Mass Storage devices
Feb 14 10:46:29 jhwx61 kernel:   Vendor: LENOVO    Model: USB_MultiBurner3  Rev:
NL31
Feb 14 10:46:29 jhwx61 kernel:   Type:   CD-ROM                             ANSI
SCSI revision: 00
Feb 14 10:46:29 jhwx61 kernel: scsi 3:0:0:0: Attached scsi generic sg1 type 5
Feb 14 10:46:35 jhwx61 kernel: sr0: scsi3-mmc drive: 24x/24x writer dvd-ram
cd/rw xa/form2 cdda tray
Feb 14 10:46:35 jhwx61 kernel: Uniform CD-ROM driver Revision: 3.20
Feb 14 10:46:39 jhwx61 hald: mounted /dev/scd0 on behalf of uid 500

Now connecting same device to right USB port:

Feb 14 10:46:47 jhwx61 kernel: usb 6-1: new high speed USB device using ehci_hcd
and address 10
Feb 14 10:46:59 jhwx61 kernel: usb 6-1: device not accepting address 10, error -110
Feb 14 10:46:59 jhwx61 kernel: usb 6-1: new high speed USB device using ehci_hcd
and address 11
Feb 14 10:47:10 jhwx61 kernel: usb 6-1: device not accepting address 11, error -110
Feb 14 10:47:10 jhwx61 kernel: usb 6-1: new high speed USB device using ehci_hcd
and address 12
Feb 14 10:47:21 jhwx61 kernel: usb 6-1: device not accepting address 12, error -110
Feb 14 10:47:21 jhwx61 kernel: usb 6-1: new high speed USB device using ehci_hcd
and address 13
Feb 14 10:47:31 jhwx61 kernel: usb 6-1: device not accepting address 13, error -110
Comment 4 Pete Zaitcev 2008-02-29 22:47:25 EST
This has nothing to do with USB. The interrupt routing on X61 is broken
for some reason. It's either an outright kernel bug, or bad ACPI tables
and we failed to work around them.

Jan, please attach an unedited dmesg to this bug (do not drop it into
the comments box).
Comment 5 Jan Wildeboer 2008-03-01 03:10:47 EST
Created attachment 296442 [details]
DMESG after reboot

as requested
Comment 6 Jan Wildeboer 2008-03-07 04:12:01 EST
It seems to be a more complex problem. Short form:

* USB 2.x devices work
* USB 1.x devices are not seen

I would like to gather some more input, but this far I have tested:

* iPod Nano - works
* Palm m515 with original USB Cradle - not working
* Palm m515 with third party hotsync USB cable - not working

Where not working means: Nothing in /var/log/messages.

So I am *suspecting* that there is a problem with USB 1.x devices only.

Jan
Comment 7 Pete Zaitcev 2008-03-07 04:47:34 EST
Comment #6 contradicts actual messages from the original report. The
report has EHCI (for bus 6) recorded throwing errors, and that's the
Hi-Speed (480 mbit/s) controller.

I'm going to ignore information in comment #6 as incorrent and consider
this failing:

ACPI: PCI Interrupt 0000:00:1d.7[D] -> GSI 19 (level, low) -> IRQ 233
ehci_hcd 0000:00:1d.7: EHCI Host Controller
ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 6

BTW, I expect booting with "noapic" or "pci=routeirq" to work around
the issue.
Comment 8 Jan Wildeboer 2008-03-07 04:55:06 EST
You can ignore my experiences at your will, however let me clarify first.

The original report was based on kernel-2.6.18-78 (i686)

Comment #6 is based on kernel-2.6.18-83 (i686)

Will try both pci=routeirq and noapic and reports results here.

Jan
Comment 9 Jan Wildeboer 2008-03-07 05:24:40 EST
So there seems to be a change between -78 and -83. I have attached a clean dmesg
for -83 for you to check.

USB 2 devices now work on all ports, so my original report seems to be solved
for USB 2.x devices. However, my palm is still not seen. Yes I modprobed visor,
yes it did work before.

Jan
Comment 10 Jan Wildeboer 2008-03-07 05:26:10 EST
Created attachment 297163 [details]
clean dmesg of -83 32bit kernel on X61
Comment 11 Pete Zaitcev 2008-03-07 13:47:02 EST
Aww, I was just going to ask for dmesgs with connect attempts, so we
know for sure which IRQ is bad in each case. If they are different,
we'll need two.

I ran diff on dmesgs in comment #5 and #10, and they are essentially
the same (minus an error -71 which is caused by EHCI disrupting the
enumeration on its companion). So, kernel does not print anything
interesting on its own. I'll need to find a way to dump the ACPI
tables and re-interpret them.
Comment 12 Pete Zaitcev 2008-03-07 14:09:03 EST
I'm behind the curve, here's the upstream bug:
 http://bugzilla.kernel.org/show_bug.cgi?id=8853
The fix is to update the BIOS to 2.06 (7NETA6WW), apparently.
Comment 13 Jan Wildeboer 2008-03-13 10:13:29 EDT
I am at 2.06 according to dmidecode. Still the problem persists. Hoiwever, there
seems to be a 2.10 BIOS which I will try ASAP.
Comment 15 Pete Zaitcev 2008-04-01 19:43:34 EDT
Jan, did BIOS 2.10 work? I need to know because our kernel 2.6.18 may
be different from what testers in Bugme used, so I have to split your
problem off the BIOS problem (it may be both).
Comment 16 Peter Martuccelli 2008-04-02 09:29:27 EDT
This is not a blocking issue for RHEL 5.2, moved the issue out to RHEL 5.3. 
Please post the latest results with the updated BIOS.
Comment 17 Peter Martuccelli 2008-08-19 15:37:34 EDT
Closing out as current release against RHEL 5.2, the kernel team does not experience any USB port failures on our x61 laptops.

Any remaining issues on Jan's laptop need to be reported in bugzilla against the latest RHEL 5.3 kernel build.

Note You need to log in before you can comment on or make changes to this bug.