Bug 432772 - Two Fedora9 Alpha partition installations make the same partition LABEL, so mistake to load wrong partition filesystem.
Two Fedora9 Alpha partition installations make the same partition LABEL, so m...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On:
Blocks: F9Blocker
  Show dependency treegraph
 
Reported: 2008-02-14 05:20 EST by Song, Youquan
Modified: 2008-04-14 13:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-14 13:30:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Song, Youquan 2008-02-14 05:20:43 EST
Description of problem:

Firstly installation of "Fedora 9 x86-64" on a partition (sorry, I can not find
the entry for F9 bug report), then install "Fedora 9 ia32" on another. Boot ia32   
will report "request_module: runaway loop modprobe binfmt-464c". I find that the
two partition with the same root=LABLE=/. After I modify the grub "root=LABEL=/
->  root=/dev/sdaX and /etc/fstab "LABEL=/ -> /dev/sdaX". the system can boot
normally.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.installation x86_64 fedora 9 Alpha on /dev/sda1
2.installation ia32 fedora 9 Alpha on /dev/sda2, install grub to MBR.
3.reboot, hange with "request_module: runaway loop modprobe binfmt-464c"
  
Actual results:


Expected results:


Additional info:
Happened in Intel Bensley platform (2xXeon 2.83G Harpertown C0, chipset
Blackford G1, 160 SATA)
Comment 1 Phil Knirsch 2008-02-14 06:21:52 EST
Reassigning to proper component (anaconda) as this looks more like an
installation/kernel problem.

Read ya, Phil
Comment 2 Chris Lumens 2008-03-14 13:38:39 EDT
This should be better in F9-Beta since we are using filesystem UUIDs instead of
labels in /etc/fstab.
Comment 3 Jeremy Katz 2008-03-14 18:18:59 EDT
We should still double check to make sure there aren't two filesystems with the
same label, though.
Comment 4 Jesse Keating 2008-04-01 17:29:23 EDT
Jeremy, I think you said this was fixed in another bug.  Setting this one to
need retesting.
Comment 5 Song, Youquan 2008-04-11 07:20:51 EDT
With UUID instead of label in FC9 beta. this bug is fixed.
Comment 6 Jon Stanley 2008-04-14 13:30:08 EDT
closing

Note You need to log in before you can comment on or make changes to this bug.