Bug 432780 - ipNetToMediaNetAddress only shows 0.0.0.0
ipNetToMediaNetAddress only shows 0.0.0.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: net-snmp (Show other bugs)
8
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Safranek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-14 06:24 EST by Jan Safranek
Modified: 2008-03-13 03:44 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.4-17.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-13 03:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Safranek 2008-02-14 06:24:19 EST
Copied from upstream bug tracker on behalf of Maciek Kolbusz
https://sourceforge.net/tracker/?func=detail&atid=112694&aid=1889739&group_id=12694

Hi Guys,

I've been working on a SNMP network scanner and found that weird thing
where some of my Linux machines (physical and virtual) showed invalid
values in ipNetToMediaTable. In ipNetToMediaNetAddress column there were
0.0.0.0 in every row. Other columns of the same table, ie.
ipNetToMediaPhysAddress, were showing correct values.

That was happening only on machines running with Fedora Core 7 and Fedora
8. Each of those had the latest version of net-snmp installed from repos
which was 5.4.1.

On one machine where Fedora Core 7 was installed I removed net-snmp
packages with yum. Then I downloaded, compiled and ran snmpd from
net-snmp-5.3.2 package and the problem was gone - agent started to give
correct values in ipNetToMediaNetAddress column.

Version 5.3.2 was just a random pick - I was looking for something older
than 5.4, as I noticed that my other machines (SuSE, Centos, FreeBSD) with
versions of net-snmp ranging from 5.0 to 5.2 installed didn't cause such
issue with invalid IPs in ipNetToMediaTable.

Let me know if there is a solution for that other than installation of
older packages.

Regards.
Maciek
Comment 1 Jan Safranek 2008-02-14 06:24:50 EST
Applies to F7,8 and Rawhide
Comment 2 Jan Safranek 2008-02-14 07:00:07 EST
Fixed in Rawhide, net-snmp-5.4.1-10.fc9. I'll release F7 and F8 updates when I
get more bugfixes.
Comment 3 Maciek Kolbusz 2008-02-14 11:04:35 EST
On Fedora 7 and 8 the bug is gone after you compile net-snmp-5.4.1 from source.
Comment 4 Fedora Update System 2008-02-29 06:23:33 EST
net-snmp-5.4-17.fc7 has been submitted as an update for Fedora 7
Comment 5 Fedora Update System 2008-02-29 06:24:38 EST
net-snmp-5.4.1-6.fc8 has been submitted as an update for Fedora 8
Comment 6 Fedora Update System 2008-03-01 04:25:36 EST
net-snmp-5.4-17.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update net-snmp'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F7/FEDORA-2008-2127
Comment 7 Fedora Update System 2008-03-13 03:41:37 EDT
net-snmp-5.4-17.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-03-13 03:44:34 EDT
net-snmp-5.4.1-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.