Bug 432795 - Add atomic operation for super-H(sh3,4) arche.
Add atomic operation for super-H(sh3,4) arche.
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
sh4 Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-14 07:58 EST by CHIKAMA Masaki
Modified: 2008-02-18 06:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 06:42:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-lib-1.0.3a-sh-linux.patch (1.72 KB, text/x-patch)
2008-02-14 07:58 EST, CHIKAMA Masaki
no flags Details

  None (edit)
Description CHIKAMA Masaki 2008-02-14 07:58:02 EST
Description of problem:
 This patch adds atomic operation for super-H(sh3,sh4) architecture.
This is forward ported patch for version alsa-lib-1.0.15-1 
getting from http://www.sh-linux.org/ .

This patch is very similar to linux kernel's atomic operation
which is in linux/include/asm-sh/atomic-grb.h .
That was added recently to kernel tree. But the origin of 
this patch is very old because it's against alsa-lib-1.0.3a
when it first appeared. It's one of lost techology ;-).

Could you contact upstream and merge it ?
Comment 1 CHIKAMA Masaki 2008-02-14 07:58:02 EST
Created attachment 294909 [details]
alsa-lib-1.0.3a-sh-linux.patch
Comment 2 Martin Stransky 2008-02-18 06:42:48 EST
Filled as https://bugtrack.alsa-project.org/alsa-bug/view.php?id=3789

Note You need to log in before you can comment on or make changes to this bug.