Bug 432809 - new 2.6.25 Kernel doesn't boot on x86_64 with root on lvm
new 2.6.25 Kernel doesn't boot on x86_64 with root on lvm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-14 10:09 EST by Sven Oehme
Modified: 2008-02-21 08:57 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 08:57:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sven Oehme 2008-02-14 10:09:55 EST
Description of problem:

if you try to boot from one of the new 2.6.25 fc9 kernels it doesn't detect any
LVM disks so failed to boot ..

Version-Release number of selected component (if applicable):

i tried : 
kernel-2.6.25-0.40.rc1.git2.fc9
kernel-2.6.25-0.35.rc1.fc9
kernel-2.6.25-0.34.rc1.fc9
as well as 
kernel-2.6.25-0.33.rc1.fc9

How reproducible:

always 

Steps to Reproduce:
1.install f8
2.update to the latest codes levels
3.install one of the above kernels .. and try to boot
  
Actual results:

doesn't find any VG, or LV so it fails to find root 

Expected results:

should boot up 


Additional info:
Comment 1 John W. Linville 2008-02-20 11:11:49 EST
It was suggested that I update lvm2 from Rawhide, so I did:

   yum --enablerepo=development update lvm2

This updated lvm2 and device-mapper:

   lvm2-2.02.33-9.fc9
   device-mapper-1.02.24-9.fc9

However, I still get the same results described by the OP.
Comment 2 John W. Linville 2008-02-20 11:30:02 EST
OK, this seemed to do it:

   yum --enablerepo=development update mkinitrd

Afterwards you'll need to re-run mkinitrd for the 2.6.25 kernels installed (or 
use yum or rpm to uninstall and reinstall them).

Does that resolve things for you?
Comment 3 Sven Oehme 2008-02-21 00:49:30 EST
yes, this Problem is now sloved .. now the kernel oopses as soon as i enter init
5 but this is definitive a different problem and i open a new bug :-) 

Note You need to log in before you can comment on or make changes to this bug.