Bug 432820 - RHEL 5.1 seemingly has no CHAP support on install
RHEL 5.1 seemingly has no CHAP support on install
Status: CLOSED DUPLICATE of bug 432819
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
All Linux
low Severity high
: rc
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2008-02-14 11:36 EST by Supreeth
Modified: 2008-02-15 16:33 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-15 16:33:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Supreeth 2008-02-14 11:36:01 EST
Description of problem:

Anaconda does not seem to have fields in the UI where the user can enter CHAP 
information to connect to an iSCSI target and install the OS onto a LUN. Since 
RHEL 5.1 provides native support for iSCSI boot/install without iBFT support, 
the user must be allowed to input CHAP/Mutual CHAP parameters via the 
installer GUI.  

Version-Release number of selected component (if applicable):
RHEL 5.1 Server

How reproducible:

Since the UI in the anaconda installer has no fields for CHAP UserName and 
Password, this issue is reproducibe whenever someone tries to connect to a 
target LUN that expects CHAP authentication.

Steps to Reproduce:
1. Enable CHAP on an iSCSI target.
2. Ensure iscsi adapter makes a connection to the target (Before int 13 via 
Option ROM)
3. Attempt to add an iscsi disk during install observe install fails.

Actual results:
Install to remote LUN fails (CHAP authentication fails, and the target LUN 
does not show up in the list of HDs to install)

Expected results:
It is expected that the user will be given a way to enter CHAP information by 
Anaconda for authentication to proceed, and upon success the user will be able 
to see the target LUN.

Additional info:
If Anaconda can pull information from the iBFT (iSCSI Boot Firmware Table) in 
future releases, the CHAP information (if any) can be retrieved from there to 
send to the target at time of install.
Comment 1 Supreeth 2008-02-14 11:42:53 EST
This is a duplicate of bug 432819. It was a double post for some reason.
Comment 2 Chris Lumens 2008-02-15 16:33:45 EST

*** This bug has been marked as a duplicate of 432819 ***

Note You need to log in before you can comment on or make changes to this bug.