Bug 432862 - [Hosted] RHN 5.0 kickstarts no longer update yum-rhn-plugin etc. in %post
[Hosted] RHN 5.0 kickstarts no longer update yum-rhn-plugin etc. in %post
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
high Severity medium
: ---
: ---
Assigned To: Mike Orazi
Bryan Kearney
US=18123
:
Depends On:
Blocks: 431812 433460
  Show dependency treegraph
 
Reported: 2008-02-14 15:22 EST by Xixi
Modified: 2013-01-10 03:46 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 16:01:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 pete oberlin 2008-02-18 16:12:48 EST
RHN Backlog-Accepted.  US# 18123 
http://wwwapps.rdu.redhat.com:8080/xplanner/do/view/userstory?oid=18123
Comment 3 Mike Orazi 2008-03-06 14:52:53 EST
The following list of rpms are now on the freshen list and appear in the %post
section as expected:

{"yum",  "yum-rhn-plugin", "rhn-setup", "rhn-check", "rhn-client-tools",
"rhnsd", "pirut"}


svn -r 118580

Comment 4 Mike Orazi 2008-03-07 18:40:28 EST
While, the wget line is executable correct AFTER the kickstart, it appears that
there are errors in ks-post.log.  

We need to do some more investigation to see what's going on with wget inside of
a ks.
Comment 5 Mike Orazi 2008-03-10 18:10:08 EDT
This error is causing wrong behaviors on RHEL 5: 
https://bugzilla.redhat.com/show_bug.cgi?id=436822

Recoded the wget lines to do individual wgets per files since there is always
only a small set of packages that we are concerned with.  

(rev 118592)

Test plan:

Ensure that this works for all versions of RHEL.

Note You need to log in before you can comment on or make changes to this bug.