Bug 432864 - Kickstart provisioning a system registered through proxy registers it to the satellite not proxy.
Kickstart provisioning a system registered through proxy registers it to the ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Partha Aji
Preethi Thomas
:
Depends On:
Blocks: 248630
  Show dependency treegraph
 
Reported: 2008-02-14 15:27 EST by Preethi Thomas
Modified: 2008-04-02 16:32 EDT (History)
0 users

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 16:32:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2008-02-14 15:27:43 EST
Description of problem:
Provisioning a system registered through proxy registers it to the satellite.

Version-Release number of selected component (if applicable):
rhn-satellite-5.1.0-143-redhat-linux-as-i386-4-embedded-oracle.iso

How reproducible:

always
Steps to Reproduce:
1. Configure a Prox through the satellite.
2. Register a client through proxy.
3. Create a kickstart profile.
4. Provision the client.
5. Once the kickstart finsihes, check the serverUrl in /etc/sysconfing/rhn/up2date
  
Actual results:
 see that the serverUrl is of the Satellite and not the proxy's

Expected results:

It should be registerd to the proxy.


Additional info:
Comment 1 Clifford Perry 2008-02-18 13:13:57 EST
this is a regression - the kickstart profile rendered when kickstarting via a
RHN Proxy should render in the RHN Proxy hostname, not the Satellite. I *think*
devan or Justin *may* of already fixed this, think I remember seeing a commit on
this last week. 

Cliff
Comment 2 Clifford Perry 2008-02-18 13:29:26 EST
SVN commit r136875 maybe - by Devan... maybe.. 
Comment 3 Devan Goodwin 2008-02-18 15:36:32 EST
Justin and I both have no knowledge of this, but picking this up as Partha is on
PTO today.
Comment 4 Devan Goodwin 2008-02-19 16:51:53 EST
Was the proxy selected on the provisioning screen? We're unable to reproduce
this and this was the only possible cause we could come up with. If that setting
were missed when scheduling the kickstart the new OS would be registered against
the satellite and not the proxy. Using that setting both the generated kickstart
file and the serverURL after kickstart points to the proxy in our testing.

Could we get QA to verify that this is an issue if the proxy is set on
provisioning screen?

Partha will be doing some more testing tonight against newer satellite code to
make sure.
Comment 5 Preethi Thomas 2008-02-20 08:26:02 EST
Devan, Partha
I wasn't selecting RHN Proxy on the kickstart page.

I do think th text Under Select RHN Proxy is misleading though. It says

"You may choose to use an RHN Proxy to access the files necessary for kickstart:"

I understood it as to get the kickstart files use Satellite or Proxy. Since I my
client was already registered to a proxy, I expected it be registered to Proxy
after kickstart whether I chose RHN Proxy or not to acess the files.

This may be something you could cosider for a future release. May be adding
another line of text warning that the client will be  registered to Satellite or
Proxy depending on your selection.

Thanks
Comment 6 Partha Aji 2008-02-20 12:16:59 EST
Changed the text to reflect the function of the proxy combo box.. Should be in
the next push..
Comment 7 Preethi Thomas 2008-02-26 11:09:55 EST
verified.
Comment 8 Corey Welton 2008-03-26 09:04:20 EDT
release_pending
Comment 9 Brandon Perkins 2008-04-02 16:32:17 EDT
Proxy 5.1.0 GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.