Bug 432916 - system-config-kickstart only set up one RAID
system-config-kickstart only set up one RAID
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-kickstart (Show other bugs)
5.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 00:10 EST by Chris Pepper
Modified: 2011-08-12 10:15 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-09 14:15:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Before and after requesting creation of md1 (see next screenshot) (74.67 KB, image/png)
2008-02-15 00:10 EST, Chris Pepper
no flags Details
Unsuccessful attempt to create md1 (68.27 KB, image/png)
2008-02-15 00:11 EST, Chris Pepper
no flags Details
Kickstart Configurator window, showing inconsistent RAID mirrors (101.04 KB, image/png)
2010-03-25 17:17 EDT, Chris Pepper
no flags Details
raid.05 Partition Options window -- note empty Mount Point (58.41 KB, image/png)
2010-03-25 17:18 EDT, Chris Pepper
no flags Details
raid.06 Partition Options window -- note Mount Point: raid.06 (59.47 KB, image/png)
2010-03-25 17:19 EDT, Chris Pepper
no flags Details

  None (edit)
Description Chris Pepper 2008-02-15 00:10:00 EST
Description of problem:
I tried to create 2 software RAID partitions. system-config-kickstart didn't create the second one (I tried 
several times).

Version-Release number of selected component (if applicable):
RHEL 5.1

How reproducible:
Several times consecutively; I didn't try relaunching s-k-c

Steps to Reproduce:
1."ssh -XY root@rhel51"
2.system-config-kickstart.
3.Partition Information.
4.Create 4 SW RAID partitions.
5.Create a mirror across raid.01 & raid.03.
6.Create a mirror across raid.02 & raid.04.
  
Actual results:
Second RAID is not created. system-config-kickstart doesn't spit out an error message, although it 
does log many GTK assertions (before and after attempting to create the second mirror)

Expected results:
Second mirror should be created.

Additional info:
[root@inspector ~]# system-config-kickstart
/usr/lib/python2.4/site-packages/pirut/GroupSelector.py:331: GtkWarning: 
gtk_tree_view_scroll_to_point: assertion `GTK_WIDGET_REALIZED (tree_view)' failed
  gobject.idle_add(lambda x: x.scroll_to_point(0, 0), tree)

/usr/share/system-config-kickstart/raidWindow.py:231: GtkWarning: gtk_tree_store_set_value: 
assertion `VALID_ITER (iter, tree_store)' failed
  self.part_store.set_value(partition_iter, 1, raid_object.raidDevice)
/usr/share/system-config-kickstart/raidWindow.py:196: GtkWarning: gtk_tree_store_append: 
assertion `VALID_ITER (parent, tree_store)' failed
  raid_device_iter = self.part_store.append(self.raid_parent_iter)
/usr/share/system-config-kickstart/raidWindow.py:197: GtkWarning: gtk_tree_store_set_value: 
assertion `VALID_ITER (iter, tree_store)' failed
  self.part_store.set_value(raid_device_iter, 0, raid_object.mountPoint)
/usr/share/system-config-kickstart/raidWindow.py:205: GtkWarning: gtk_tree_store_set_value: 
assertion `VALID_ITER (iter, tree_store)' failed
  self.part_store.set_value(raid_device_iter, 0, raid_object.raidDevice)
/usr/share/system-config-kickstart/raidWindow.py:206: GtkWarning: gtk_tree_store_set_value: 
assertion `VALID_ITER (iter, tree_store)' failed
  self.part_store.set_value(raid_device_iter, 1, raid_object.mountPoint)
/usr/share/system-config-kickstart/raidWindow.py:207: GtkWarning: gtk_tree_store_set_value: 
assertion `VALID_ITER (iter, tree_store)' failed
  self.part_store.set_value(raid_device_iter, 2, raid_object.fsType)
/usr/share/system-config-kickstart/raidWindow.py:208: GtkWarning: gtk_tree_store_set_value: 
assertion `VALID_ITER (iter, tree_store)' failed
  self.part_store.set_value(raid_device_iter, 5, raid_object)
/usr/share/system-config-kickstart/raidWindow.py:214: GtkWarning: gtk_tree_store_set_value: 
assertion `VALID_ITER (iter, tree_store)' failed
  self.part_store.set_value(raid_device_iter, 3, (_("Yes")))
Comment 1 Chris Pepper 2008-02-15 00:10:00 EST
Created attachment 294974 [details]
Before and after requesting creation of md1 (see next screenshot)
Comment 2 Chris Pepper 2008-02-15 00:11:13 EST
Created attachment 294975 [details]
Unsuccessful attempt to create md1
Comment 3 Chris Lumens 2009-01-20 11:07:52 EST
Can you test the version in F10 and let me know if it's working better for you?  I was unable to reproduce this problem testing against a previous version of Fedora as well as RHEL5, so I'm unsure as to the current status for you.
Comment 4 Chris Pepper 2010-03-22 12:23:38 EDT
Fedora 12 doesn't have system-config-kickstart. Is it gone or renamed?
Comment 5 Chris Lumens 2010-03-22 14:36:58 EDT
Sure it does:  http://koji.fedoraproject.org/koji/buildinfo?buildID=131968
Comment 6 Chris Pepper 2010-03-25 17:17:36 EDT
Created attachment 402685 [details]
Kickstart Configurator window, showing inconsistent RAID mirrors
Comment 7 Chris Pepper 2010-03-25 17:18:32 EDT
Created attachment 402686 [details]
raid.05 Partition Options window -- note empty Mount Point
Comment 8 Chris Pepper 2010-03-25 17:19:43 EDT
Created attachment 402687 [details]
raid.06 Partition Options window -- note Mount Point: raid.06
Comment 9 Chris Pepper 2010-03-25 17:21:01 EDT
Sorry, I didn't realize system-config-kickstart is now a non-default package in F12.

More oddness. I created 4 SW RAID partitions with the Add button, then 2 software RAIDs on top wit the RAID button. For the first one I typed 1000 into the "Fixed size" box before selecting the Grow button, then later noticed my mistake and changed Fixed size back to 1 for consistency. But both in the window and in the kickstart file, 2 mirrored volumes don't match. I don't know how one got raid.06 in its Mount Point field, though.

But they do both appear in the kickstart file, which is a big improvement.

# Disk partitioning information
part raid.01 --fstype="raid" --ondisk=sda --size=1000
part raid.03 --fstype="raid" --ondisk=sda --size=1000
part raid.02 --fstype="raid" --ondisk=sdb --size=1000
part raid.04 --fstype="raid" --ondisk=sdb --size=1000
part  --fstype="raid" --grow --maxsize=1 --ondisk=raid.01 raid.02 --size=1
part raid.06 --fstype="raid" --grow --maxsize=1 --ondisk=raid.03 raid.04 --size=1
Comment 10 David Cantrell 2011-08-09 14:15:41 EDT
Please contact your Red Hat technical support representative for help with software in RHEL.  Problems discovered in the software this way are then properly escalated and prioritized for development.

If you do not want to take that approach, file the bug against Fedora and help work a fix in to Fedora.  The next major release (e.g., RHEL x.0) will inherit the fix that way.
Comment 11 Chris Pepper 2011-08-12 10:15:40 EDT
I don't use Fedora. I am not asking for support. I'm reporting a bug in RHEL.

Note You need to log in before you can comment on or make changes to this bug.