Bug 432931 - unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2: cpio: rename with RHEL4U6->RHEL5.2 upgrade
unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2: cpi...
Status: CLOSED DUPLICATE of bug 432773
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 04:43 EST by Alexander Todorov
Modified: 2008-02-19 10:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 10:30:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2008-02-15 04:43:51 EST
Description of problem:
Multiple error messages in upgrade.log related to gcc.

Version-Release number of selected component (if applicable):
gcc-4.1.2-39.el5.ia64.rpm
gcc-c++-4.1.2-39.el5.ia64.rpm
gcc-gfortran-4.1.2-39.el5.ia64.rpm
gcc-gnat-4.1.2-39.el5.ia64.rpm
gcc-java-4.1.2-39.el5.ia64.rpm
gcc-objc-4.1.2-39.el5.ia64.rpm
gcc-objc++-4.1.2-39.el5.ia64.rpm

RHEL5.2-Server-20080212.0

How reproducible:
100%

Steps to Reproduce:
1. Install RHEL4-U6-AS, @everything
2. Upgrade to RHEL5.2-Server-20080212.0 with anaconda
3. check /root/upgrade.log
  
Actual results:
multiple errors in upgrade.log

Expected results:
no errors

Additional info:
sees this on i386, ia64 and ppc

Error(s) installing: libstdc++-devel 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: cpp 4.1.2 39.el5 ia64
error: unpacking of archive failed on file
/usr/libexec/gcc/ia64-redhat-linux/4.1.2: cpio: rename
Error(s) installing: gcc 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: gcc-c++ 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: gcc-gfortran 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: gcc-gnat 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: gcc-objc 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: libmudflap-devel 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: libgcj 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcj-4.1.2: cpio: rename
Error(s) installing: libgcj-devel 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Error(s) installing: gcc-java 4.1.2 39.el5 ia64
error: unpacking of archive failed on file /usr/lib/gcc/ia64-redhat-linux/4.1.2:
cpio: rename
Comment 3 James Laska 2008-02-19 08:44:08 EST
Something changed in RHEL4 or RHEL5 that regressed the major release upgrade
test result.

This failure was not observed when upgrading from RHEL-4/U5 -> RHEL-5/U1.

Retesting RHEL-4/U5 -> RHEL-5/U2 upgrades in KATE now.  Will post back with
results.  This should help narrow down what introduces this change in behavior
(a RHEL4 change or RHEL5 change).

May also test RHEL-4/U6 -> RHEL-5/U1 upgrades.  The combination should narrow
down the guilty party.
Comment 5 Brock Organ 2008-02-19 10:30:36 EST

*** This bug has been marked as a duplicate of 432773 ***

Note You need to log in before you can comment on or make changes to this bug.