Bug 43294 - sa never reports any io
sa never reports any io
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: psacct (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-06-02 17:57 EDT by Tim Clymo
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2005-167
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-17 03:11:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Clymo 2001-06-02 17:57:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-tc i686; Nav)

Description of problem:
Run command sa - here are the first few lines of the output from my system:

  386095   53947.37re      41.10cp         0avio       459k
      48    6326.80re       5.57cp         0avio      1686k   ***other*
   10630      20.18re       5.07cp         0avio       538k   ifup-post
       2    1330.09re       3.69cp         0avio     11685k   X
   10629       3.89re       3.29cp         0avio       556k   ifup-routes
   42657       2.78re       2.32cp         0avio       347k   sed
   10628       5.39re       2.03cp         0avio       588k   ifup-aliases
   85028       3.76re       1.87cp         0avio       540k   ifup-post*
   53145       3.79re       1.66cp         0avio       537k   ifup-aliases*
       5     712.21re       1.62cp         0avio      3149k  
netscape-naviga
   21345       1.67re       1.31cp         0avio       380k   basename
     443       1.24re       1.04cp         0avio       401k   cp
       2       3.63re       0.53cp         0avio       354k   updatedb
   31885       1.06re       0.31cp         0avio       381k   hostname
       6     357.10re       0.21cp         0avio      2033k  
gnome-terminal
    3645       0.19re       0.17cp         0avio       386k   date
   21485       1.84re       0.16cp         0avio       405k   grep

As you can see, each and every line reports 0 for average io. Running sa -D
gives a pretty similar result except that all the total io's are 0 instead

How reproducible:
Always

Steps to Reproduce:
1. Run "sa" or "sa -D"
2.
3.
	

Additional info:
Comment 1 Tim Clymo 2001-08-17 03:37:56 EDT
This is still broken in Roswell - can somebody take a look?
Comment 2 Mike A. Harris 2002-11-13 16:19:59 EST
Is this issue still relevant in Red Hat Linux 7.2, 7.3 and/or 8.0?
Comment 3 Tim Clymo 2002-11-18 14:45:39 EST
Still relevant in 8.0
Comment 4 Charlie Bennett 2004-08-27 10:01:23 EDT
Still relevant in Fedora Core 3.  I recall looking at this some time
ago.  It does not appear that the Linux kernel collects that
information in the task struct for the process making it unavailable
for accounting.

I'll take another pass through it.  There may be nothing we can do but
update the documentation.
Comment 5 Ivana Varekova 2005-02-17 03:11:46 EST
Thank you for your notice
The problem was fixed (fixed version is 6.3.2-35)
Ivana Varekova
Comment 6 Tim Powers 2005-05-19 19:39:13 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-211.html

Note You need to log in before you can comment on or make changes to this bug.