Bug 432960 - pirut can't start
pirut can't start
Status: CLOSED DUPLICATE of bug 428850
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
noarch Linux
low Severity urgent
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 08:28 EST by Dark*Metal
Modified: 2008-02-15 09:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 09:09:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the bug reports (7.21 KB, application/octet-stream)
2008-02-15 08:28 EST, Dark*Metal
no flags Details

  None (edit)
Description Dark*Metal 2008-02-15 08:28:12 EST
Component: pirut
Summary: TBdf16452e aliases.py:27:<module>:ImportError: No module named i18n

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 476, in main
    pm = PackageManager(options.config, options.onlyrepo)
  File "/usr/sbin/pirut", line 63, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 132, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 116, in
doConfigSetup
    errorlevel=errorlevel)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 160, in _getConfig
    startupconf.pluginconfpath,disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 306, in
doPluginSetup
    plugin_types, confpath, disabled_plugins)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 145, in __init__
    self._importplugins(types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 186, in
_importplugins
    self._loadplugin(modulefile, types)
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 203, in _loadplugin
    module = imp.load_module(modname, fp, pathname, description)
  File "/usr/lib/yum-plugins/aliases.py", line 27, in <module>
    from i18n import _
ImportError: No module named i18n

Local variables in innermost frame:
CliError: None
__builtins__: {'IndexError': <type 'exceptions.IndexError'>, 'all': <built-in
function all>, 'help': Type help() for interactive help, or help(object) for
help about object., 'vars': <built-in function vars>, 'SyntaxError': <type
'exceptions.SyntaxError'>, 'unicode': <type 'unicode'>, 'UnicodeDecodeError':
<type 'exceptions.UnicodeDecodeError'>, 'isinstance': <built-in function
isinstance>, 'copyright': Copyright (c) 2001-2007 Python Software Foundation.
All Rights Reserved.

Copyright (c) 2000 BeOpen.com.
All Rights Reserved.

Copyright (c) 1995-2001 Corporation for National Research Initiatives.
All Rights Reserved.

Copyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.
All Rights Reserved., 'NameError': <type 'exceptions.NameError'>, 'dict': <type
'dict'>, 'input': <built-in function input>, 'oct': <built-in function oct>,
'SystemExit': <type 'exceptions.SystemExit'>, 'StandardError': <type
'exceptions.StandardError'>, 'repr': <built-in function repr>, 'sorted':
<built-in function sorted>, 'False': False, 'RuntimeWarning': <type
'exceptions.RuntimeWarning'>, 'list': <type 'list'>, 'iter': <built-in function
iter>, 'reload': <built-in function reload>, 'Warning': <type
'exceptions.Warning'>, 'round': <built-in function round>, 'dir': <built-in
function dir>, 'cmp': <built-in function cmp>, 'set': <type 'set'>, 'reduce':
<built-in function reduce>, 'intern': <built-in function intern>, 'issubclass':
<built-in function issubclass>, 'Ellipsis': Ellipsis, 'EOFError': <type
'exceptions.EOFError'>, 'locals': <built-in function locals>, 'slice': <type
'slice'>, 'FloatingPointError': <type 'exceptions.FloatingPointError'>, 'sum':
<built-in function sum>, 'getattr': <built-in function getattr>, 'abs':
<built-in function abs>, 'exit': Use exit() or Ctrl-D (i.e. EOF) to exit,
'True': True, 'FutureWarning': <type 'exceptions.FutureWarning'>,
'ImportWarning': <type 'exceptions.ImportWarning'>, 'None': None, 'hash':
<built-in function hash>, 'len': <built-in function len>, 'credits':     Thanks
to CWI, CNRI, BeOpen.com, Zope Corporation and a cast of thousands
    for supporting Python development.  See www.python.org for more
information., 'frozenset': <type 'frozenset'>, '__name__': '__builtin__', 'ord':
<built-in function ord>, 'super': <type 'super'>, 'TypeError': <type
'exceptions.TypeError'>, 'license': See http://www.python.org/2.5/license.html,
'KeyboardInterrupt': <type 'exceptions.KeyboardInterrupt'>, 'UserWarning': <type
'exceptions.UserWarning'>, 'filter': <built-in function filter>, 'range':
<built-in function range>, 'staticmethod': <type 'staticmethod'>, 'SystemError':
<type 'exceptions.SystemError'>, 'BaseException': <type
'exceptions.BaseException'>, 'pow': <built-in function pow>, 'RuntimeError':
<type 'exceptions.RuntimeError'>, 'float': <type 'float'>, 'MemoryError': <type
'exceptions.MemoryError'>, 'StopIteration': <type 'exceptions.StopIteration'>,
'globals': <built-in function globals>, 'divmod': <built-in function divmod>,
'enumerate': <type 'enumerate'>, 'apply': <built-in function apply>,
'LookupError': <type 'exceptions.LookupError'>, 'open': <built-in function
open>, 'quit': Use quit() or Ctrl-D (i.e. EOF) to exit, 'basestring': <type
'basestring'>, 'UnicodeError': <type 'exceptions.UnicodeError'>, 'zip':
<built-in function zip>, 'hex': <built-in function hex>, 'long': <type 'long'>,
'ReferenceError': <type 'exceptions.ReferenceError'>, 'ImportError': <type
'exceptions.ImportError'>, 'chr': <built-in function chr>, 'xrange': <type
'xrange'>, 'type': <type 'type'>, '__doc__': "Built-in functions, exceptions,
and other objects.\n\nNoteworthy: None is the `nil' object; Ellipsis represents
`...' in slices.", 'Exception': <type 'exceptions.Exception'>, 'tuple': <type
'tuple'>, 'UnicodeTranslateError': <type 'exceptions.UnicodeTranslateError'>,
'reversed': <type 'reversed'>, 'UnicodeEncodeError': <type
'exceptions.UnicodeEncodeError'>, 'IOError': <type 'exceptions.IOError'>,
'hasattr': <built-in function hasattr>, 'delattr': <built-in function delattr>,
'setattr': <built-in function setattr>, 'raw_input': <built-in function
raw_input>, 'SyntaxWarning': <type 'exceptions.SyntaxWarning'>, 'compile':
<built-in function compile>, 'ArithmeticError': <type
'exceptions.ArithmeticError'>, 'str': <type 'str'>, 'property': <type
'property'>, 'GeneratorExit': <type 'exceptions.GeneratorExit'>, 'int': <type
'int'>, '__import__': <built-in function __import__>, 'KeyError': <type
'exceptions.KeyError'>, 'coerce': <built-in function coerce>,
'PendingDeprecationWarning': <type 'exceptions.PendingDeprecationWarning'>,
'file': <type 'file'>, 'EnvironmentError': <type 'exceptions.EnvironmentError'>,
'unichr': <built-in function unichr>, 'any': <built-in function any>, 'OSError':
<type 'exceptions.OSError'>, 'DeprecationWarning': <type
'exceptions.DeprecationWarning'>, 'min': <built-in function min>,
'UnicodeWarning': <type 'exceptions.UnicodeWarning'>, 'execfile': <built-in
function execfile>, 'id': <built-in function id>, 'complex': <type 'complex'>,
'bool': <type 'bool'>, 'ValueError': <type 'exceptions.ValueError'>,
'NotImplemented': NotImplemented, 'map': <built-in function map>, 'buffer':
<type 'buffer'>, 'max': <built-in function max>, 'object': <type 'object'>,
'TabError': <type 'exceptions.TabError'>, 'callable': <built-in function
callable>, 'ZeroDivisionError': <type 'exceptions.ZeroDivisionError'>, 'eval':
<built-in function eval>, '__debug__': True, 'IndentationError': <type
'exceptions.IndentationError'>, 'AssertionError': <type
'exceptions.AssertionError'>, 'classmethod': <type 'classmethod'>,
'UnboundLocalError': <type 'exceptions.UnboundLocalError'>,
'NotImplementedError': <type 'exceptions.NotImplementedError'>,
'AttributeError': <type 'exceptions.AttributeError'>, 'OverflowError': <type
'exceptions.OverflowError'>}
__file__: None
time: None
sys: None
TYPE_INTERACTIVE: None
__name__: None
__doc__: None
Comment 1 Dark*Metal 2008-02-15 08:28:12 EST
Created attachment 295004 [details]
the bug reports
Comment 2 James Antill 2008-02-15 09:09:00 EST

*** This bug has been marked as a duplicate of 428850 ***

Note You need to log in before you can comment on or make changes to this bug.