Bug 432983 - libcap needs to be updated!
libcap needs to be updated!
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libcap (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Karsten Hopp
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 11:14 EST by Jonathan Kamens
Modified: 2013-01-09 23:34 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-15 15:01:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-02-15 11:14:55 EST
With today's Rawhide update, named no longer starts:

Starting named: named: capset failed: Invalid argument: please ensure that the 
capset kernel module is loaded.  see insmod(8)
^[[60G[^[[0;31mFAILED^[[0;39m]

According to http://lkml.org/lkml/2008/2/6/533, the problem is an out-of-date 
libcap.  Apparently libcap in Rawhide needs to be updated and named needs to be 
linked against the newest libcap.
Comment 1 Karsten Hopp 2008-02-15 15:01:16 EST
I've built libcap-2.06-1.fc9 in Rawhide. Named isn't linked against libcap at
all, so I wonder how this is could be the cause for your problems.
Comment 2 Karsten Hopp 2008-02-18 06:40:34 EST
the new libcap has a different soname and I've untagged it from rawhide as I
need to notify the maintainers of dependent packages first.
Comment 3 Kevin Kofler 2008-02-20 02:13:44 EST
And now it has reappeared due to the rel-eng GCC 4.3 autorebuilds. This breaks 
dependencies on core components like dbus-libs and is also causing many of the 
subsequent autorebuilds to fail.
Comment 4 Karsten Hopp 2008-02-20 06:21:21 EST
$%#&!

I've built a new libcap (2.06-3) package that should fix these problems.

Note You need to log in before you can comment on or make changes to this bug.