Bug 433035 - fanout example doesn't fan-out
fanout example doesn't fan-out
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: Messaging_Programming_Reference (Show other bugs)
beta
All Linux
low Severity low
: ---
: ---
Assigned To: Alan Conway
Kim van der Riet
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 14:55 EST by Alan Conway
Modified: 2012-09-21 09:02 EDT (History)
0 users

See Also:
Fixed In Version: B4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-17 15:47:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Conway 2008-02-15 14:55:33 EST
Description of problem:


The fanout example is poorly written, it does not actually demonstrate what the
fan-out exchange does.

The fanout exchange copies messages to every queue that is bound to it, however
the example only binds
a single queue, so there's nowhere to fan out to. The listeners all bind to the
same queue and compete
for messages. If there are just a few then they're likely to all end up on the
same consumer,
because the broker delivers messages in batches for higher throughput.

I've attached a modified listener.cpp that creates a private queue for each
listener. If you start multiple
listeners you'll see they all get all the messages.
Comment 1 Alan Conway 2008-02-15 16:03:08 EST
New example in revision 628151
Comment 2 Jonathan Robie 2008-05-17 15:47:52 EDT
It does fan out now, in both Python and C++.

There is no fanout example in Java. We should fix that for GA.
Comment 3 Jonathan Robie 2008-05-20 14:09:51 EDT
Closing - the Java part of this issue is recorded in
https://bugzilla.redhat.com/show_bug.cgi?id=433036.

Note You need to log in before you can comment on or make changes to this bug.