Bug 433067 - traceback when creating a new user with a login name of "4"
traceback when creating a new user with a login name of "4"
Status: CLOSED DUPLICATE of bug 432136
Product: freeIPA
Classification: Community
Component: ipa-admintools (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
Depends On:
Blocks: 429034
  Show dependency treegraph
Reported: 2008-02-15 17:04 EST by Michael Gregg
Modified: 2015-01-04 18:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-20 16:10:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Gregg 2008-02-15 17:04:11 EST
Description of problem:
See summary and steps to reproduce.

How reproducible:

Steps to Reproduce:
1. configure a client to connect to a ipa server. 
2. As root, kinit as admin.
3. run ipa-adduser
4. specify firstname: 1
5. lastname: 2
6. Login name: 3
7. Password: 4

Actual results:
Traceback (most recent call last):
  File "/usr/share/ipa/ipaserver/ipaxmlrpc.py", line 171, in _marshaled_dispatch
    response = self._dispatch(method, params)
  File "/usr/share/ipa/ipaserver/ipaxmlrpc.py", line 204, in _dispatch
    ret = func(*args)
  File "/usr/lib/python2.4/site-packages/ipaserver/funcs.py", line 492, in add_user
    dn="uid=%s,%s,%s" % (ldap.dn.escape_dn_chars(user['uid']),
KeyError: 'uid'

Expected results:
If this is expected behavior as the login name is very short, throw a error
message that states this to the console, or the log, or both.
Comment 1 Rob Crittenden 2008-02-20 16:10:41 EST
This was fixed in 432136.

The difference is that bug reported it in the UI and this one the CLI, same
issue though.

Fixed in changeset 642

*** This bug has been marked as a duplicate of 432136 ***

Note You need to log in before you can comment on or make changes to this bug.