Bug 433075 - bind-9.5.0-26.b2.fc9 will not start
bind-9.5.0-26.b2.fc9 will not start
Status: CLOSED DUPLICATE of bug 433102
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-15 17:50 EST by Hal Duston
Modified: 2013-04-30 19:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 07:22:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Duston 2008-02-15 17:50:51 EST
Description of problem:
named fails to start

Version-Release number of selected component (if applicable):
9.5.0-26.b2.fc9

How reproducible:
Always

Steps to Reproduce:
1.service named start
2.observe message below
3.
  
Actual results:
capset failed: Invalid argument:
 please ensure that the capset kernel
 module is loaded.  see insmod(8)

Expected results:
named running.

Additional info:
fails on kernel-2.6.24-0.80.rc4.git6.fc9.i686
fails on kernel-2.6.24-0.123.rc6.fc9.i686
fails on kernel-2.6.24.1-31.fc9.i586

Reverting to bind-9.5.0-25.b1.fc9 restored functionality on all three kernels 
above

strace reveals:
capset(0x20071026, 0, 
{CAP_DAC_READ_SEARCH|CAP_SETGID|CAP_SETUID|CAP_NET_BIND_SERVICE|CAP_SYS_CHROOT|C
AP_SYS_RESOURCE, 
CAP_DAC_READ_SEARCH|CAP_SETGID|CAP_SETUID|CAP_NET_BIND_SERVICE|CAP_SYS_CHROOT|CA
P_SYS_RESOURCE, 0}) = -1 EINVAL (Invalid argument)
Comment 1 Adam Tkac 2008-02-18 07:22:35 EST
Problem is due new kernel capability interface. Lets track this bug under #433102

*** This bug has been marked as a duplicate of 433102 ***

Note You need to log in before you can comment on or make changes to this bug.