Bug 433079 - Installer traceback from F9 alpha on x86_64 using raid and encryption
Installer traceback from F9 alpha on x86_64 using raid and encryption
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F9Beta
  Show dependency treegraph
 
Reported: 2008-02-15 19:40 EST by Bruno Wolff III
Modified: 2008-03-18 12:17 EDT (History)
1 user (show)

See Also:
Fixed In Version: booty-0.97-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 12:17:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback dump from the installer (16.49 MB, text/plain)
2008-02-15 19:40 EST, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2008-02-15 19:40:05 EST
Description of problem:


Version-Release number of selected component (if applicable):
F9 alpha release

How reproducible:
I had one failure before it got to where it did, but I think that might have
been a bad read from the rescue cd. I also had a very simple install work (no
encryption, no raid). I have gotten it to fail at this point at least twice
using essentially the same set up.

Steps to Reproduce:
1. It looks like the traceback file has the info you want for this
2.
3.
  
Actual results:
Install failed

Expected results:
Install succeeded

Additional info:
After the installer crashed it locked up for a while and then prompted me about
each raid array (probably each place it was going to install something). It
seemed odd that it locked up for a long time, but perhaps it was trying to
contact a redhat server and I had to wait for a timeout. Also it was odd that it
complained that the raid 1 arrays (using software raid) without encryption were
unusable because they were loopback devices. These should be OK as grub can use
either element of such an array and will treat them as ext3.
Unfortunately I haven't been able to grab a set of post alpha x86_64 images as
the compose has been failing almost every night recently.
Comment 1 Bruno Wolff III 2008-02-15 19:40:08 EST
Created attachment 295055 [details]
Traceback dump from the installer
Comment 2 Jeremy Katz 2008-02-20 18:31:34 EST
dlehman committed a fix for something which might have been this earlier today
Comment 3 Will Woods 2008-03-12 11:31:41 EDT
Does current rawhide work here?
Comment 4 David Lehman 2008-03-13 12:24:10 EDT
This should have been fixed in whatever tree first contained booty-0.97-1,
somewhere around 24 Feb 2008. Is this still an issue for you?
Comment 5 Bruno Wolff III 2008-03-15 21:41:31 EDT
I haven't actually tested an install recently. I have been doing rescues instead.
If the problem was the same for both, then it is fixed. Otherwise I am not sure.
Comment 6 David Lehman 2008-03-18 12:17:50 EDT
I think the traceback, which seems to be the bug reported here, is fixed. If you
find this to be untrue please reopen the bug.

Note You need to log in before you can comment on or make changes to this bug.