Bug 4331 - Function "passed" logged as "succeeded"
Summary: Function "passed" logged as "succeeded"
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-03 13:12 UTC by Jos Vos
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-03 13:31:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos Vos 1999-08-03 13:12:20 UTC
When the function "passed" is called from some init script
(like after doing fsck in rc.sysinit), it will be displayed
as "[PASSED]" (which is OK), but it will be logged via
syslog as "succeeded", because both "success" and "passed"
use the "-e 1" option of initlog.  This can be rather
confusing, so maybe initlog should get another -e option,
which is logged as "partial failure" or so.

Comment 1 Bill Nottingham 1999-08-03 13:31:59 UTC
Maybe; it's currently logged as succeeded because it is
a successful fsck, even if it was forced to check (sometimes
it's forced to check because of the mount count, etc.)

Of course, if it's completely unsuccessful, you're dropped
to a shell, so it doesn't get logged anyways. ;)

We'll think about this for a future release.


Note You need to log in before you can comment on or make changes to this bug.