Bug 433100 - [RFE] smolt should provide a way to collect statistics when offline
[RFE] smolt should provide a way to collect statistics when offline
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
https://hosted.fedoraproject.org/smolt/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 06:00 EST by Răzvan Sandu
Modified: 2009-06-22 16:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 13:01:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-02-16 06:00:53 EST
Description of problem:

smolt should provide a mechanism to collect hardware statistic & save them in a
file, in order to send them afterwards, if no network connection can be achieved
on the inspected machine.

Public smolt server should provide users a way to submit those statistics
collected offline.

A standardised file format (maybe OpenDocument or other type of XML ?) should be
used for storing data.

Version-Release number of selected component (if applicable):
smolt-1.0-2.fc8


May thanks,
Răzvan
Comment 1 Paul W. Frields 2008-08-09 12:17:48 EDT
Triage here.  Any status change for current smolt?
Comment 2 Mike McGrath 2008-08-09 13:54:16 EDT
No progress.  This bug should really be opened against https://fedorahosted.org/smolt/ but either way no one really has time to work on this.

In order to send stats some box has to be online.  And its possible for that box to just act as a proxy.  Its a corner case right now, there's really not that many machines that don't have access to the internet.  Not saying they don't exist but for the ones that don't have it, it wouldn't be terribly difficult to enable access.
Comment 3 Răzvan Sandu 2008-08-16 11:32:16 EDT
Hello,

Regarding comment #2:

Please imagine the scenario when a hardware salesman has a LiveCD in his pocket and can boot in Linux all his 30-40 laptops on his shelf. Very fast, he can send to the smolt site very precise hardware profiles of these machines, providing *invaluable* (and unaltered) data to driver developers...

These laptops usually don't have Internet access, so a way of capturing the standard report in a file and sending it to the smolt site afterwards (from an Internet-connected computer) would be imensely helpful.

BTW, if one looks to the smolt site, he will notice some interesting facts:

1. Only Fedora is present. That means other very popular distros, such as CentOS, Ubuntu, RHEL or Debian, still miss a *quick, reliable and automatic way* to run smolt and report their hardware...

For example, I personally run a network of about 30 CentOSes (growing) and I've installed automatic smolt and LinuxCounter scripts on all of them (enabling epel repo especially for the sake of smolt...). My machines are still not seen in statistics (probably because I'm under 100 - but I'm sure more people will report if all is simple and automatic)...

2. Compared to the quick adoption of Fedora 8 and Fedora 7, Fedora 9 lags behind (after a long time since its release). IMHO, this was due to the initial instability in the NetworkManager zone, which prohibited a reliable connection to the network even on Ethernet.


Best regards,
Răzvan
Comment 4 Mike McGrath 2009-06-22 13:01:10 EDT
I think you're missing the point.  Ubuntu, Centos, RHEL, etc... don't include it as part of first boot.  Thats why it's only got Fedora.  An offline stats module is not something I have any interest in doing since, at the end of the day, it requires something to be online.

The "collect and update later" scenario is one that can be argued but I'd imagine it'd account for less then .1% of the people that register with smolt *and* they'd quickly get removed as they would be considered stale after 3 months and no checkins.
Comment 5 Răzvan Sandu 2009-06-22 16:26:18 EDT
One final observation:

IMHO, smolt provides two kind of information:

1. Statistics about distro, default runlevel, kernel version, etc.
2. Actual hardware information about components

I think point #2 is *by far* the most important for any Linux distro, because it provides driver developers with information that they can't get otherwise (because they don't actually own the all the hardware).

Point #1 is also important, but only as a marketing/comparison/statistics tool.

"Convincing" Red Hat to include smolt at firstboot in RHEL (both desktop and server versions), exactly as it is in Fedora, would be an *immense* benefit for all the community. It would drive smolt in the business segment (inside the companies) - to scan more diverse and sophisticated hardware and provide a more fine-grained picture of the hardware Linux runs on.

Information about hardware is extremely valuable even if the profile doesn't get updated monthly. IMHO, unlike "statistics" (point #1), the hardware information (point #2) should not "expire": the fact that mainboard X contains chipset Y remains valid even if the mainboard is no longer in mainstream use.

I'm personally using *smolt on a Live CD* to report info about exotic hardware (especially laptops). There are many times where the scanned system simply has no Internet acces, for various reasons. IMHO, providing a way to get the smolt report in offline mode and submit it later, from another machine, would be a basic feature.

IMHO, all discussions about the way smolt reports statistics data at firstboot is of secondary importance compared to reporting *hardware information* from as many machines as possible.


Best regards,
Răzvan
Comment 6 Mike McGrath 2009-06-22 16:45:33 EDT
Actually Red Hat has nothing to do with this, I'm smolt upstream.  I happen to work for red hat.  I'm happy to take patches.  The data is sent via a json string.  I'm sure it could be saved and loaded.  I just don't have the time to do this nor do I see the direct value.  But I don't want to say no to someone else if they want to do the work.

Note You need to log in before you can comment on or make changes to this bug.