This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 433104 - Deskbar applet keeps crashin
Deskbar applet keeps crashin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: deskbar-applet (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 06:41 EST by Peter Janakiev
Modified: 2016-09-19 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.21.91-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-07 11:18:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Janakiev 2008-02-16 06:41:53 EST
Description of problem:
After the update to the latest version of the applet whenever I try to enter a
new search in it, the bug buddy is started with information that the applet has
crashed (while it is actually still there and after I close bug buddy it
displays the search results. It does not matter if it is setup to stick to the
panel or to display separate window. 


Version-Release number of selected component (if applicable):
deskbar-applet-2.21.90.1-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. Press Alt + F3 (hotkey for activating deskbar applet) or press the icon in
the panel
2. Type a letter in the entry
3. after closing the bug buddy window type another one
  
Actual results:
Bug buddy is started, promting to submit a bug entry. After closing it the
results are displayed in the deskbar window

Expected results:
Display the results right away

Additional info:

Bug buddy trace
raceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/deskbar/ui/CuemiacWindowView.py", line
222, in append_matches
    self.treeview_model.append (matches, self.entry.get_text())
  File "/usr/lib/python2.5/site-packages/deskbar/ui/cuemiac/CuemiacModel.py",
line 142, in append
    self.__append_match(hit, query_string)
  File "/usr/lib/python2.5/site-packages/deskbar/ui/cuemiac/CuemiacModel.py",
line 129, in __append_match
    iter = self.__append ( query_string, match_obj )
  File "/usr/lib/python2.5/site-packages/deskbar/ui/cuemiac/CuemiacModel.py",
line 155, in __append
    iter = self.__create_category_with_match (qstring, match_obj)
  File "/usr/lib/python2.5/site-packages/deskbar/ui/cuemiac/CuemiacModel.py",
line 173, in __create_category_with_match
    iter = self.__append_match_to_iter (iter, qstring, match_obj)
  File "/usr/lib/python2.5/site-packages/deskbar/ui/cuemiac/CuemiacModel.py",
line 192, in __append_match_to_iter
    action = match_obj.get_actions()[0]
IndexError: list index out of range
Comment 1 Luke Macken 2008-02-16 15:08:27 EST
Could you give this build a shot ?

http://koji.fedoraproject.org/koji/getfile?taskID=432246&name=deskbar-applet-2.21.91-1.fc8.i386.rpm
Comment 2 Peter Janakiev 2008-02-16 15:38:51 EST
Works for me, haven't had the time to test all enabled plugins but the reported
problem is resolved.

Thanks
Comment 3 Fedora Update System 2008-02-16 19:15:57 EST
deskbar-applet-2.21.91-1.fc8 has been submitted as an update for Fedora 8
Comment 4 Fedora Update System 2008-02-18 22:13:53 EST
deskbar-applet-2.21.91-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update deskbar-applet'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1775
Comment 5 Fedora Update System 2008-04-29 16:50:42 EDT
deskbar-applet-2.21.91-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.