Bug 433105 - [RFE] Try to integrate smolt with The Linux Counter
[RFE] Try to integrate smolt with The Linux Counter
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
https://hosted.fedoraproject.org/smolt/
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 06:41 EST by Răzvan Sandu
Modified: 2009-06-22 16:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-22 13:02:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2008-02-16 06:41:56 EST
Description of problem:

The Linux Counter , founded by Harald Alvestrand (http://counter.li.org) has a
long tradition of collecting statistics about Linux machines.

The project offers a script, called „machine-update”, that periodically updates
some data (http://counter.li.org/scripts/).

However, this has a few disadvantages:
- it is not automatic (machine-update must be installed and updated manually)
- not all data initially collected by the script is updated automatically

On the other hand, smolt has far better hardware data collection and level of
automatism.

I think both projects should benefit if the statistics collected are unified in
a common format and a common collecting "script" is distributed to users, in
.rpm, .deb packages.

Please consider unifying and automating the mechanism of collecting statistics
and distribute .rpm packages.
Comment 1 Răzvan Sandu 2008-12-21 10:44:06 EST
There is one more information that worths to be added here:

hardware4linux.info seems to be Debian's official choice for a hardware profiler, equivalent to smolt - please see:

http://hardware4linux.info/

Even RPM packages for this tool are officially available:

http://hardware4linux.info/download/

IMHO, integrating as much as possible these three projects (goals, protocols, mechanisms, resources, etc.) and making hardware data collection as automatic as possible will *greatly* enlarge the opportunities to write 100% free drivers for various hardware and, ultimately, increase Linux adoption.

We cannot afford getting trapped in distribution-based "religious wars", since this will only serve the cause of proprietary software.

So PLEASE search for an unification mechanism.

Regards,
Răzvan
Comment 2 Răzvan Sandu 2009-01-31 15:44:22 EST
Hello,


After studying online a lot more about this, I'm able to say there are at least five significant projects with similar goals:


- smolt (https://fedorahosted.org/smolt);

- The Linux Counter (http://counter.li.org), via the machine-update script (http://counter.li.org/scripts/machine-update);

- hardware4linux.info (http://www.hardware4linux.info), which seems to be the preferred tool in Debian/Ubuntu/Kiwi;

- FSF's Linux Inventory Aggregator (http://www.dracoware.com/ppl/rtwomey/inventory.shtml, please see details at http://www.fsf.org/resources/hw).

- Hardinfo (http://hardinfo.berlios.de/HomePage), which seems to have a Gentoo flavour.


IMHO, we need a cross-distribution hardware profiler, as *automatic* as possible and with *maximum details* about the hardware it scans.

We also need a Windows tool to scan computers we *prospect* to run Linux, in order to quickly submit to driver developers as much informatuon as possible about new or "exotic" hardware on the market.


Regards,
Răzvan
Comment 3 Mike McGrath 2009-01-31 20:25:53 EST
Sorry, I don't want to make it sound like I'm ignoring you but everything you've mentioned has already been thought of and discussed.


Ideas we have plenty of.

What we're missing is coders.
Comment 4 Mike McGrath 2009-06-22 13:02:36 EDT
Also, smolt has a ticketing system - 

https://fedorahosted.org/smolt/

If the owners of those websites thought it was important for smolt to be integrated with them.. They'd have contacted me.  You're asking me to do work to benefit them, which is good valuable work, don't get me wrong.  But I don't have the time to do it, and if they don't see the value in doing it I'm not sure why I should.
Comment 5 Răzvan Sandu 2009-06-22 16:52:14 EDT
I agree with your dissapointment, but I will not comment that here. 

I systematically scan all hardware I have at hand (in my company) with these tools:

- smolt
- hardware4linux.info
- LinuxCounter (if there's a machine permanently running Linux)
- GNU's Linux Aggregator
- lspci -vvv

and I submit the complete data to hardware@gnu.org (please see http://www.fsf.org/resources/hw)

Not being a coder myself, this my (very modest) way to contribute to the general effort: provide free driver developers with as much hardware information as possible. I have a strong conviction that good quality free drivers are esential in Linux mass adoption, especially in the desktop segment.

Please note that I'm not only scanning machines that actually run Linux in my company's network (routers, servers), but any computer that I suspect having more "exotic" hardware, etc.

In this respect, having a "pocket tool" that will gain as much hardware information as possible, in an automatic way, would be an immense benefit.


Best regards,
Răzvan

Note You need to log in before you can comment on or make changes to this bug.