Bug 433108 - Upgrade by yum is refused
Upgrade by yum is refused
Status: CLOSED DUPLICATE of bug 433096
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 07:43 EST by antonio montagnani
Modified: 2008-02-16 12:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-16 12:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description antonio montagnani 2008-02-16 07:43:32 EST
Description of problem:

When you run yum update xulrunner you get an error
Version-Release number of selected component (if applicable):
xulrunner-1.9-0.beta3.21.nightly20080214.fc9.i386

How reproducible:
always 

Steps to Reproduce:
1.run yum update xulrunner
2.
3.
  
Actual results:
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xulrunner.i386 0:1.9-0.beta3.21.nightly20080214.fc9 set
to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Updating:
 xulrunner               i386       1.9-0.beta3.21.nightly20080214.fc9
 development       9.5 M

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       1 Package(s)
Remove       0 Package(s)

Total download size: 9.5 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): xulrunner-1.9-0.be 100% |=========================| 9.5 MB    00:36
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
 Updating  : xulrunner                    ######################### [1/2]
Error unpacking rpm package xulrunner-1.9-0.beta3.21.nightly20080214.fc9.i386
errore: estrazione archivio fallita sul file
/usr/lib/xulrunner-1.9pre/dictionaries: cpio: rename

Updated: xulrunner.i386 0:1.9-0.beta3.21.nightly20080214.fc9
Complete!

Expected results:
update

Additional info:
Comment 1 Remi Collet 2008-02-16 09:14:59 EST
I think it's rather a "yum" bug which doesn't handle the change 
from a folder (up to 0.beta3.20) to an link (in 0.beta3.21).

Regards
Comment 2 Christopher Aillon 2008-02-16 12:15:01 EST

*** This bug has been marked as a duplicate of 433096 ***

Note You need to log in before you can comment on or make changes to this bug.