Bug 433131 - ppp reports various Protocol-Reject for unsupported protocol
ppp reports various Protocol-Reject for unsupported protocol
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Nagy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 12:07 EST by Peter Bieringer
Modified: 2016-07-26 19:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 11:45:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bieringer 2008-02-16 12:07:24 EST
Description of problem:

During load on ppp interface (using PPPoE), various Protocol-Rejects are seen in
log.

Version-Release number of selected component (if applicable):

ppp-2.4.4-2
rp-pppoe-3.8-1.fc7

How reproducible:

On more or less high ppp load every 10 to 30 seconds, sometimes more often

Actual results:

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:****  P-t-P:*****  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:435216 errors:438196 dropped:0 overruns:0 frame:0
          TX packets:346143 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:489546292 (466.8 MiB)  TX bytes:120732542 (115.1 MiB)

Example from log:

Feb 16 18:04:10 * pppd[*]: Protocol-Reject for unsupported protocol 0xb8db
Feb 16 18:04:26 * pppd[*]: Protocol-Reject for unsupported protocol 0x9a9a
Feb 16 18:04:41 * pppd[*]: Protocol-Reject for unsupported protocol 0xaf
Feb 16 18:04:42 * pppd[*]: Protocol-Reject for unsupported protocol 0xa0cd
Feb 16 18:05:08 * pppd[*]: Protocol-Reject for unsupported protocol 0xe7
Feb 16 18:05:11 * pppd[*]: Protocol-Reject for unsupported protocol 0xb22e



Expected results:

No such errors.


Additional info:

I'm more or less stumped, what's going on. I've captured some packets on the
Ethernet inteface and found, that the packets (where also tcpdump claims about
unknown ppp protocol) did not contain IP payload.

The related ethernet interface (8139too module) do not show any link error, so
it looks like that at least layer 2 from NIC to DSL modem is ok.

Are there any hints available what can causing this problem? I found only rare
results on Google.
Comment 1 Martin Nagy 2008-03-06 11:45:53 EST
Looks like this is not a bug. Please search /usr/share/doc/ppp-2.4.4/FAQ for
"Protocol-Reject". Closing as NOTABUG.
Comment 2 Peter Bieringer 2008-03-08 07:40:00 EST
Thank you for your comment, just for information, after switching the pppoe
daemon  back to asynchronos, such messages no longer appear, also, the error
counter of the ppp interface stays 0 now.
/etc/sysconfig/network-scripts/ifcfg-ppp0:

..
#SYNCHRONOUS=yes
SYNCHRONOUS=no
...

Note You need to log in before you can comment on or make changes to this bug.