Bug 433138 - WebKit-gtk-devel has a requirement on qt4-devel
WebKit-gtk-devel has a requirement on qt4-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: WebKit (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 15:33 EST by Erik van Pienbroek
Modified: 2008-03-02 05:24 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.0.0-0.6.svn30667.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-02 05:24:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erik van Pienbroek 2008-02-16 15:33:29 EST
I just wanted to try out the WebKit-gtk package which has recently landed in
rawhide for one of my own projects. While installing the WebKit-gtk-devel
package yum mentioned that also qt4-devel was required. This looks kinda silly
to me because I only want the GTK bits of WebKit.

$ sudo yum install WebKit-gtk-devel

Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package WebKit-gtk-devel.i386 0:1.0.0-0.4.svn29336.fc9 set to be updated
--> Processing Dependency: libWebKitGtk.so.1 for package: WebKit-gtk-devel
--> Processing Dependency: qt4-devel for package: WebKit-gtk-devel
--> Processing Dependency: WebKit-gtk = 1.0.0-0.4.svn29336.fc9 for package:
WebKit-gtk-devel
--> Running transaction check
---> Package WebKit-gtk.i386 0:1.0.0-0.4.svn29336.fc9 set to be updated
---> Package qt4-devel.i386 0:4.3.3-6.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 WebKit-gtk-devel        i386       1.0.0-0.4.svn29336.fc9  development        19 k
Installing for dependencies:
 WebKit-gtk              i386       1.0.0-0.4.svn29336.fc9  development       2.8 M
 qt4-devel               i386       4.3.3-6.fc9      development       6.5 M

Transaction Summary
=============================================================================
Install      3 Package(s)
Update       0 Package(s)
Comment 1 Peter Gordon 2008-02-16 16:40:59 EST
Unfortunate as it might be, WebKit currently uses qmake and friends for its
build scripts. Thus, it needs the qt4-devel package for those utilities and data
files. 

Work is underway upstream to transition the GTK+ bits to autotools (since WebKit
is/will be integrated with Qt in a future version). So once that is done the
Fedora package will follow suit. Until then, however, both the Qt and GTK+ ports
of WebKit both build using qmake, so this dependency is a necessary one.

Thanks for the bug report!
Comment 2 Mamoru TASAKA 2008-03-01 13:44:24 EST
Perhaps this is a confusion between BuildRequies <-> Requires?

WebKit GTK part needs qt4-devel for BuildRequires, but
WebKit-gtk-devel really need "Requires (not BuildRequies) qt4-devel"?
Comment 3 Erik van Pienbroek 2008-03-01 13:59:10 EST
Well, if you look at the files which are bundled with the gtk-devel subpackage...

$ rpmquery --fileprovide WebKit-gtk-devel
/usr/include/WebKit	
/usr/include/WebKit/JavaScriptCore	
/usr/include/WebKit/JavaScriptCore/JSBase.h	
/usr/include/WebKit/JavaScriptCore/JSContextRef.h	
/usr/include/WebKit/JavaScriptCore/JSObjectRef.h	
/usr/include/WebKit/JavaScriptCore/JSStringRef.h	
/usr/include/WebKit/JavaScriptCore/JSStringRefBSTR.h	
/usr/include/WebKit/JavaScriptCore/JSStringRefCF.h	
/usr/include/WebKit/JavaScriptCore/JSValueRef.h	
/usr/include/WebKit/JavaScriptCore/JavaScriptCore.h	
/usr/include/WebKit/webkit.h	
/usr/include/WebKit/webkitdefines.h	
/usr/include/WebKit/webkitnetworkrequest.h	
/usr/include/WebKit/webkitwebframe.h	
/usr/include/WebKit/webkitwebview.h	
/usr/lib/libWebKitGtk.prl	
/usr/lib/libWebKitGtk.so	
/usr/lib/pkgconfig/WebKitGtk.pc	

... you'll see there is a .prl file included. This file is something belonging
to qmake. As fas as I know, developers of GTK-based applications don't use qmake
for compiling their packages, so in my opinion this file can be safely removed.
But that's something I leave up to the maintainer of webkit to decide.
Comment 4 Peter Gordon 2008-03-02 02:02:45 EST
I just checked the prl file and it seems to contain only information regarding
how WebKit was built, now how to build applications against it.

I'll fix this up shortly. Thanks for the information!
Comment 5 Peter Gordon 2008-03-02 05:24:24 EST
The .prl data and the qt4-devel runtime dependency have been removed from
WebKit-gtk-devel in Rawhide; and thus I believe this issue has been
appropriately fixed. Please re-open this bug with further details if this is not
the case. Thanks.

Note You need to log in before you can comment on or make changes to this bug.