Bug 433162 - RFE: include an open/shared option in the network gui
RFE: include an open/shared option in the network gui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.1
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-16 20:45 EST by Bill
Modified: 2009-01-20 16:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
* the combobox for wireless interfacess lacked an option for "open/shared" authentication for networks using WEP. This meant that system-config-network could not be used to configure the network adapter for this type of connection. This updated version of system-config-network allows the user to select "open/shared" authentication for use with a network protected by WEP.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:54:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill 2008-02-16 20:45:33 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Description of problem:
My system will not connect to a WEP enabled network.  It will connect to an open network.  I have tried every combination of string/hex, dashes, and capitol/lowercase letters that might work.  I have also tried entering the key through /etc/sysconfig/network-scripts/keys-eth1, iwconfig, and the system-config-network.  The wireless card has the bcm4318 chipset and the driver is ndiswrapper/xp.  The bcm43xx driver never worked.  After attempting to enter a WEP key, the system will not connect to an unsecured network until after a restart.

Version-Release number of selected component (if applicable):
system-config-network-1.3.99-2.el5

How reproducible:
Always


Steps to Reproduce:
1.Enter WEP key
2.activate wireless network adapter

Actual Results:
The system doesn't connect to the router.

Expected Results:
The system should have connected to the router.

Additional info:
Error message:

Determining IP information for eth1... failed; no link present.  Check cable?
Comment 1 Bill 2008-02-16 20:58:13 EST
This bug may be similar similar: 300431

but the workaround has no effect so this seemed different enough to get its own
report.
Comment 2 Bill 2008-02-16 21:03:40 EST
'iwlist scan' detects the network I'm trying to connect to at 100/100 quality.
Comment 3 Bill 2008-02-16 23:18:30 EST
I changed the authentication type from open to both and now it works.

Is it possible to include an open/shared option in the network gui for
simplicity of use?

Severity downgraded.

Not a bug
Comment 4 Bill 2008-02-17 00:33:11 EST
Sorry, it's still a bug.  

The system reports that a connection has been made using open wep encryption but
I cannot connect to the router interface of the internet.  Shared wep encryption
works.  

Additionally, whenever using the system-config-network gui, it automatically
tries to change the key from open to shared.  (It asks to save changes when
exiting the app, when activating or deactivating a connection or when changing a
setting.  If you answer yes, it changes the key from open to shared.)  

Sorry for all the posts, I'm still trying to figure out exactly what's going on.
Comment 8 Phil Knirsch 2008-05-05 09:20:44 EDT
After talking with the developer about this bug proposing it for RHEL-5.3 and 
granting Devel ACK for it.

Read ya, Phil
Comment 9 RHEL Product and Program Management 2008-06-02 16:18:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 14 Ruediger Landmann 2009-01-07 23:14:59 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
* the combobox for wireless interfacess lacked an option for "open/shared" authentication for networks using WEP. This meant that system-config-network could not be used to configure  the network adapter for this type of connection. This updated version of system-config-network allows the user to select "open/shared" authentication for use with a network protected by WEP.
Comment 15 errata-xmlrpc 2009-01-20 16:54:22 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0193.html

Note You need to log in before you can comment on or make changes to this bug.