Bug 433179 - SELinux is preventing sshd (sshd_t) "write" to log (dir_dev_t).
SELinux is preventing sshd (sshd_t) "write" to log (dir_dev_t).
Status: CLOSED DUPLICATE of bug 433173
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Josef Kubin
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 01:34 EST by Tim McConnell
Modified: 2008-02-18 12:08 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 12:08:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim McConnell 2008-02-17 01:34:09 EST
Description of problem:
SELinux denied access requested by sshd. It is not expected that this access
    is required by sshd and this access may signal an intrusion attempt. It is
    also possible that the specific version or configuration of the application
    is causing it to require additional access.


Version-Release number of selected component (if applicable):
selinux-policy-strict-2.6.4-70.fc7
selinux-doc-1.26-1.1
selinux-policy-mls-2.6.4-70.fc7
selinux-policy-2.6.4-70.fc7
selinux-policy-devel-2.6.4-70.fc7
selinux-policy-targeted-2.6.4-70.fc7


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Allowing Access
    Sometimes labeling problems can cause SELinux denials.  You could try to
    restore the default system file context for log, restorecon -v log If this
    does not work, there is currently no automatic way to allow this access.
    Instead,  you can generate a local policy module to allow this access - see
    http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385 Or you can disable
    SELinux protection altogether. Disabling SELinux protection is not
    recommended. Please file a http://bugzilla.redhat.com/bugzilla/enter_bug.cgi
    against this package.

Additional Information        

Source Context                system_u:system_r:sshd_t:SystemLow-SystemHigh
Target Context                system_u:object_r:dir_dev_t
Target Objects                log [ sock_file ]
Affected RPM Packages         
Policy RPM                    selinux-policy-2.6.4-70.fc7
Selinux Enabled               True
Policy Type                   seedit
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   plugins.catchall_file
Host Name                     timmieland.private
Platform                      Linux timmieland.private 2.6.23.14-64.fc7 #1 SMP
                              Sun Jan 20 23:54:08 EST 2008 i686 athlon
Alert Count                   3
First Seen                    Sat 16 Feb 2008 10:35:27 PM MST
Last Seen                     Sat 16 Feb 2008 10:37:26 PM MST
Local ID                      b6b0bacf-0bd6-4c8f-9e20-6d511b8de0b3
Line Numbers                  

Raw Audit Messages            

avc: denied { write } for comm="sshd" dev=tmpfs name="log" pid=2512
scontext=system_u:system_r:sshd_t:s0-s0:c0.c1023 tclass=sock_file
tcontext=system_u:object_r:dir_dev_t:s0
Comment 1 Josef Kubin 2008-02-18 10:31:02 EST
Would you shortly describe to me, how can I reproduce it?
Your configuration file is welcome, thank you!
Comment 2 Daniel Walsh 2008-02-18 12:08:15 EST

*** This bug has been marked as a duplicate of 433173 ***

Note You need to log in before you can comment on or make changes to this bug.