Bug 433185 - GLHanoi xscreensaver speed option is not available
GLHanoi xscreensaver speed option is not available
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xscreensaver (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 04:07 EST by Stewart Hardie
Modified: 2008-02-17 17:01 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 06:18:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stewart Hardie 2008-02-17 04:07:24 EST
Description of problem:
The GLHanoi xscreensaver, which can be executed as a standalone program, does
not recognise the 'speed' option. The man page for glhanoi says the '-speed
number' option set the speed of disk animation. However, running

/usr/libexec/xscreensaver/glhanoi -speed 15

shows the following output:
-----------------------
GLHanoi: from the XScreenSaver 5.04-1 distribution (13-Nov-2007.)
         http://www.jwz.org/xscreensaver/

Unrecognised option: -speed
Options include: -root, -window, -mono, -install, -noinstall, 
                 -visual <arg>, -window-id <arg>, -pair, -light, -no-light, 
                 -fog, -no-fog, -texture, -no-texture, -count <arg>, 
                 -delay <arg>, -wireframe, -no-wireframe, -fps, -no-fps.
-----------------------

This is inconsistent with the man page. Perhaps the version of GLhanoi is an old
which does not have the latest options built in??

Version-Release number of selected component (if applicable):
xscreensaver.i386  1:5.04-1.fc8

How reproducible:
Always

Steps to Reproduce:
1. View man page for glhanoi. See 'speed' option.
2. Run glhanoi with 'speed' option.
3. Output says 'speed' option is unrecognised option.
  
Actual results:
Does not run with speed option.

Expected results:
Run glhanoi with varying speeds set by that option.

Additional info:
Comment 1 Mamoru TASAKA 2008-02-17 06:18:32 EST
Thank you for reporting this bug.

Well, actually glhanoi has never supported -speed option
and the error message is correct.

As xscreensaver has more than 200 hacks there are sometimes mistakes
in the description in man package :( I will ask Jamie to fix glhanoi
man page from next version.

By the way, if you want to change the speed of glhanoi, please try
to use -delay option (I guess most hacks support -delay option since
5.00)
Comment 2 Stewart Hardie 2008-02-17 17:01:44 EST
The -delay option controls the speed of the camera velocity as it flies around.
What I was interested in is speeding up the speed of the colored disks as they
move from one pole to another ie. number of colored disk movements per minute.
This seems to be set by the -speed option as detailed in the man page. The
actual implementation of this option would be useful, especially with larger
numbers of colored disks.

In addition, there are other options in glhanoi man page which are not actually
available when glhanoi is run.

Note You need to log in before you can comment on or make changes to this bug.