Bug 433197 - libdhcp-devel misses dependency on libnl-devel
libdhcp-devel misses dependency on libnl-devel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libdhcp (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 08:23 EST by Carsten Clasohm
Modified: 2008-04-17 17:14 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 17:14:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carsten Clasohm 2008-02-17 08:23:15 EST
Description of problem:
After installing libdhcp-devel on an x86_64 system, "pkg-config --cflags
libdhcp" fails with an error unless one manually installs libnl-devel.x86_64.

Version-Release number of selected component (if applicable):
libdhcp-devel-1.27-4.fc8
libnl-devel-1.0-0.15.pre8.git20071218.fc8

How reproducible:
always

Steps to Reproduce:
1. Have a system where libnl-devel.i386 is installed, but libnl-devel.x86_64 is not.
2. Run "yum install libdhcp-devel", which installs both the i386 and x86_64
versions.
3. Run "pkg-config --cflags libdhcp"
  
Actual results:
You get the following error message:

Package libnl-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libnl-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libnl-1', required by 'libdhcp', not found

Expected results:
pkg-config should work for libdhcp.

Additional info:
I guess this is because libdhcp-devel has a dependency on "libnl-devel", without
specifying the architecture.
Comment 1 David Cantrell 2008-04-17 17:14:59 EDT
This does not happen with rawhide, so I'm closing it as RAWHIDE.  If you need an update for F-8, I can do 
that, but libdhcp is really only needed to build anaconda anyway.

Note You need to log in before you can comment on or make changes to this bug.