Bug 433200 - firefox-debuginfo vs. xulrunner-debuginfo conflict
Summary: firefox-debuginfo vs. xulrunner-debuginfo conflict
Keywords:
Status: CLOSED DUPLICATE of bug 417791
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner
Version: rawhide
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-17 15:43 UTC by Jan Kratochvil
Modified: 2018-04-11 18:14 UTC (History)
4 users (show)

Fixed In Version: firefox-debuginfo-3.0-0.beta3.22.nightly20080215.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-20 16:13:43 UTC


Attachments (Terms of Use)

Description Jan Kratochvil 2008-02-17 15:43:13 UTC
+++ This bug was initially created as a clone of Bug #432806 +++

Description of problem:
Installation of firefox-debuginfo together with xulrunner-debuginfo fails.

Not sure if it is worth fixing, see the bottom.

Version-Release number of selected component (if applicable):
firefox-debuginfo-3.0-0.beta3.21.nightly20080214.fc9.i386
xulrunner-debuginfo-1.9-0.beta3.22.nightly20080215.fc9.i386

How reproducible:
Did not try.

Steps to Reproduce:
1. yum --enablerepo='*-debuginfo' install firefox-debuginfo xulrunner-debuginfo

Actual results:
Updating:
 firefox                 i386       3.0-0.beta3.21.nightly20080214.fc9 
development       1.4 M
 firefox-debuginfo       i386       3.0-0.beta3.21.nightly20080214.fc9 
development-debuginfo  625 k
 xulrunner               i386       1.9-0.beta3.22.nightly20080215.fc9 
development       9.5 M
 xulrunner-debuginfo     i386       1.9-0.beta3.22.nightly20080215.fc9 
development-debuginfo   64 M

Transaction Check Error:
  file /usr/src/debug/mozilla/memory/jemalloc/jemalloc.c conflicts between
attempted installs of firefox-debuginfo-3.0-0.beta3.21.nightly20080214.fc9.i386
and xulrunner-debuginfo-1.9-0.beta3.22.nightly20080215.fc9.i386

Expected results:
Installed two debuginfo packages.

Additional info:
Not sure if it is worth fixing as it would get probably fixed automatically with
F10 and its multiple-simultaneous-debuginfo-versions-installed feature.
There were some draft patches for it which created /usr/src/debug/NAME-NVR
directory for each package but not sure what solution will hit F10:
  http://people.redhat.com/jkratoch/multidebug/

Comment 2 Martin Stransky 2008-02-19 17:06:30 UTC
is fixed in 1.9-0.beta3.23, right?

Comment 3 Andrew Farris 2008-02-19 22:09:31 UTC
Actually that conflict was fixed in 3.22.nightly20080215, it was just the 0214 nightly of firefox that had 
the issue.  The 0215 version of both are working together.

The 3.23 build failed for firefox, I can't check that yet, but I think this problem was dealt with.

Comment 4 Jan Kratochvil 2008-02-20 16:13:43 UTC
Confirming the problem currently does not reproduce:

WRONG:
firefox-debuginfo-3.0-0.beta3.21.nightly20080214.fc9.i386.rpm 
-rw-r--r--    1 root    root           155464 Feb 13 20:56
/usr/src/debug/mozilla/memory/jemalloc/jemalloc.c
xulrunner-debuginfo-1.9-0.beta3.22.nightly20080215.fc9.i386.rpm
-rw-r--r--    1 root    root           155965 Feb 15 21:11
/usr/src/debug/mozilla/memory/jemalloc/jemalloc.c

OK:
firefox-debuginfo-3.0-0.beta3.22.nightly20080215.fc9.i386.rpm 
-rw-r--r--    1 root    root           155965 Feb 15 21:11
/usr/src/debug/mozilla/memory/jemalloc/jemalloc.c
xulrunner-debuginfo-1.9-0.beta3.23.nightly20080217.fc9.i386.rpm
-rw-r--r--    1 root    root           155965 Feb 15 21:11
/usr/src/debug/mozilla/memory/jemalloc/jemalloc.c

OTOH it is currently IMO still buggy as just the both builds use the same
library version now.  The sources may differ again in the future.

As some files are apparently built in both packages (and no shared by some .so)
you should place both source trees into distinct directories - such as using the
.spec %prep option `-c'.


Comment 5 Christopher Aillon 2008-02-22 06:21:05 UTC

*** This bug has been marked as a duplicate of 417791 ***


Note You need to log in before you can comment on or make changes to this bug.