Bug 433206 - gl-117 doen not rebuild correctly
gl-117 doen not rebuild correctly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gl-117 (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 11:22 EST by Christoph Karl
Modified: 2008-07-30 16:10 EDT (History)
0 users

See Also:
Fixed In Version: 1.3.2-7.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-30 16:10:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christoph Karl 2008-02-17 11:22:03 EST
Description of problem:
Trying to rebuild gl-117 with mock is not possible.

Version-Release number of selected component (if applicable):
gl-117-1.3.2-4.fc7.src.rpm                                                    

How reproducible:
always

Steps to Reproduce:
1.
mock -r fedora-8-i386 --rebuild gl-117-1.3.2-4.fc7.src.rpm
  
Actual results:
g++  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -I/usr/include -I/usr/include  -lm -lGL -lGLU -lglut -o 
gl-117  main.o gl.o model.o 3ds.o audio.o land.o glland.o aiobject.o effects.o 
vertexarray.o net.o mathtab.o dirs.o objload.o pilots.o loader_tga.o object.o 
conf.o mission.o cockpit.o common.o menu.o fileloader.o 
maploader.o  -L/usr/X11R6/lib -L/usr/lib -L/usr/lib -lGL -lGLU -lglut -lSDL -lSDLmain
/usr/bin/ld: cannot find -lSDLmain
collect2: ld returned 1 exit status
make[2]: *** [gl-117] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/gl-117-1.3.2-src/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/gl-117-1.3.2-src'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.97702 (%build)

Expected results:
Clean rebuild

Additional info:
Due to this line in the output:
/usr/bin/ld: cannot find -lSDLmain
it seems that the library SDLmain is missing. ???
Comment 1 Fedora Update System 2008-07-03 20:00:00 EDT
gl-117-1.3.2-7.fc8 has been submitted as an update for Fedora 8
Comment 2 Fedora Update System 2008-07-06 02:16:54 EDT
gl-117-1.3.2-7.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update gl-117'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-6151
Comment 3 Christoph Karl 2008-07-06 08:39:55 EDT
gl-117-1.3.2-7.fc8 builds correct in a Fedora 8 environment.
Thank you
Comment 4 Fedora Update System 2008-07-30 16:10:00 EDT
gl-117-1.3.2-7.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.