Bug 433210 - gettext does not rebuild if java is installed
Summary: gettext does not rebuild if java is installed
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gettext   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-17 16:52 UTC by Christoph Karl
Modified: 2008-04-24 02:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 02:15:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christoph Karl 2008-02-17 16:52:42 UTC
Description of problem:
gettext does not rebuild

Version-Release number of selected component (if applicable):
gettext-0.16.1-12.fc8.src.rpm

How reproducible:
Always

Steps to Reproduce:
rpmbuild --rebuild gettext-0.16.1-12.fc8.src.rpm
  
Actual results:
[...]
Checking for unpackaged 
file(s): /usr/lib/rpm/check-files /var/tmp/gettext-0.16.1-12.fc8-Z30767
error: Installed (but unpackaged) file(s) found:
   /usr/share/gettext/libintl.jar

Expected results:
Clean rebuild.

Additional info:
It seems that the configure script detects an installed Java version and
then automatically builds a jar file.
This jar file is than not packed.
Using mock gives a clean rebuild.
See also Bug numpy: 432194
Basic question is:
Should it be possible to rebuild inside a fully installed fedora 8 
environment,
or is it sufficient to be able to rebuild inside a "mock environment"?
My current results are:
Rebuild 661 RPMs:
645 RPMs rebuild OK,
13 ERR (till now 2 (this and 432194) are due to other installed packages,
1 (432192) is something else, rest I am still analysing.)

Comment 1 Jens Petersen 2008-02-18 00:56:28 UTC
Ok, thanks - fixing this in gettext-0.17-4.fc9.

It doesn't really see worth fixing for f8 unless there is something
else more urgent to fix too IMHO.


Note You need to log in before you can comment on or make changes to this bug.