Bug 433213 - gpgme does not rebuild
Summary: gpgme does not rebuild
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gpgme (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-17 17:23 UTC by Christoph Karl
Modified: 2008-02-18 13:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 13:52:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Christoph Karl 2008-02-17 17:23:12 UTC
Description of problem:
Trying to rebuild gpgme does not work

Version-Release number of selected component (if applicable):
gpgme-1.1.5-4.fc8.src.rpm

How reproducible:
Always

Steps to Reproduce:
mock -r fedora-8-i386 --rebuild gpgme-1.1.5-4.fc8.src.rpm 
  
Actual results:
From build.log:
[...]
PASS: t-encrypt
PASS: t-verify
Hallo Leute!
PASS: t-decrypt
t-sign.c:107: KSBA: Not found (9.27)
FAIL: t-sign
[...]

Expected results:
Clean rebuild

Additional info:

Comment 1 Rex Dieter 2008-02-17 17:33:07 UTC
clearly, it did build fine (at one time anyway) in fedora's buildsys:
http://koji.fedoraproject.org/koji/buildinfo?buildID=16097

Comment 2 Rex Dieter 2008-02-18 13:52:57 UTC
Odd, but I can confirm the problem using gpgme-1.1.6 (maybe it's the fact of
using gnupg2-2.0.8 to build).  Either way, that's the reason this comment is in
the specfile:

%check
# expect 1(+?) errors with gnupg < 1.2.4
# gpgme-1.1.6 includes one known failure (FAIL: t-sign)
make check ||:

Upstream is aware of the 'make check' failure, and said it's mostly harmless
(and should be fixed in an upcoming release).



Note You need to log in before you can comment on or make changes to this bug.