Bug 433214 - anaconda network install fails without DHCP server
anaconda network install fails without DHCP server
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 12:25 EST by Vadym Chepkov
Modified: 2009-09-08 12:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-08 12:07:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file example (1.21 KB, text/plain)
2008-02-17 12:25 EST, Vadym Chepkov
no flags Details

  None (edit)
Description Vadym Chepkov 2008-02-17 12:25:02 EST
Description of problem:
When you try to do a network install of Fedora 8 (I tried both original dvd and
Fedora unity spin from 02/04/08) using a kickstart file (again I used boot.iso
image and rescue disk, results are the same) without DHCP server present, the
installation goes into an endless loop demanding existence of DHCP server.

This is how to reproduce:
have a kicktart file with commands
install 
url --url http://server/dvd/

if you specify kickstart file on the network (ks=http://server/ks.cfg) it tries
to find DHCP server (asknetwork boot parameter doesn't make any difference),
after timout asks to provide interface settings, accepts them retrieves the
content of the kickstart file and after that goes into endless loop trying to
find DHCP server.

I attached my kiststart file, results are the same even if I put it into a
floppy disk or even if I put all interface network parameters into boot prompt
(ip= gateway= dns= ksdevice= netmask=)
Comment 1 Vadym Chepkov 2008-02-17 12:25:02 EST
Created attachment 295105 [details]
kickstart file example
Comment 2 Vadym Chepkov 2008-02-17 12:29:06 EST
According to a message during boot it's anaconda 11.3.0.50
Comment 3 Vadym Chepkov 2008-02-17 12:51:27 EST
It looks like it is seriously broken

I started DHCP server on the network.
It doesn't work anyway. If a kickstart file is on the network first DHCP request
gets an address, kickstart file is downloaded, then according to Alt-F3 output
another DHCP request follows, gets the same IP and installation fails with errors:

add: failed - 17: Netlink Error (errno = File exists)
nic_configure: failed to add routes.
result of pumpSetupInterface is DHCP configuration failed - 1 Operation not
permitted. 
Comment 4 Chris Lumens 2008-02-18 11:06:22 EST
This should be fixed in F9.  Reassigning to David as he would know for sure.
Comment 5 Edgar Hoch 2008-03-20 00:12:35 EDT
I got the same error on a notebook using F8 unity 20080204 i386 rescue cd and
dhcp and kickstart.
This means that I still can't do automatic kickstart installation with F8.

Please can it be fixed in the next fedora unity respin?
Thanks a lot in advance!
Comment 6 Bug Zapper 2008-11-26 04:50:46 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Jon Stanley 2008-11-26 12:37:23 EST
As this bug is in MODIFIED, Fedora believes that a fix has been committed that resolves the problem listed in this bug report.

If this is not the case, please re-open this report, noting the version of the package that you reproduced the bug against.

Thanks for the report!
Comment 8 Vadym Chepkov 2008-12-13 12:15:29 EST
The fix doesn't work in Fedora 10

How to reproduce:

Start installation in a segment without DHCP server, press TAB to add options:

ks=http://server/install.cfg asknetwork

A window appears "Waiting for NetworkManager to configure eth0 ..."

On tty4 you can see it sends DHCPDISCOVER, finally gives up and another window appear: "The was an errror configuring your network interface" Retry. And it goes in circle, so it is impossible to continue with installation.
Comment 9 Jonathan S. Shapiro 2008-12-18 11:11:47 EST
In F8, at least, this problem was not actually triggered by the presence of a kickstart file. It was triggered by the presence of any network-based install method. I haven't tested F10 yet.

But I would like to suggest escalating the priority on this for F10, because it creates some significant problems for virtual machine installs. In many production settings, VMs will be configured as bridged, and they are usually assigned MAC addresses dynamically. This means that they cannot be served from a central DHCP server (because the MAC address is not known in advance), and they also can't be straightforwardly served by something like dnsmasq (because you are bridged on a public network segment).

I'm aware that the MAC address can be wired down. In my case, the problem is that I'm deploying publicly visible guests on softlayer infrastructure. They don't run DHCP services at all, so even if I wire the MAC it won't help.

Now the really silly part of this in F8 is that the correct static network configuration is sitting right there in the kickstart file, which has already been loaded. The problem is not that loader2 is trying to configure the network. The problem is that it throws away the kickstart information that tells it how to go about doing so.
Comment 10 Adam Huffman 2009-03-05 11:11:40 EST
This appears to be what I'm seeing on an F8 VM.  I've tried using Preupgrade to go to F10, but see the same symptoms listed in https://bugzilla.redhat.com/show_bug.cgi?id=433214#c8 i.e. NetworkManager fails to pick up an IP address so the installer becomes stuck in a loop - offering to retry with no chance of an exit, except resetting the VM.
Comment 11 Joel Andres Granados 2009-09-08 12:07:40 EDT
I recently did a non-dhcp install.  No endless loops or tracebacks in sight.  I tested with current rawhide.  Feel free to reopen this if you see this with current rawhide.

Note You need to log in before you can comment on or make changes to this bug.