Bug 433215 - anaconda kickstart installation ignores selinux parameter
Summary: anaconda kickstart installation ignores selinux parameter
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 8
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-17 17:38 UTC by Vadym Chepkov
Modified: 2008-03-25 17:15 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-25 17:15:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Vadym Chepkov 2008-02-17 17:38:17 UTC
Original Fedora 8 DVD, and Fedora Unity spin from 02/04/2008 during kickstart
installation ignore 'selinux --disabled' kickstart configuration. After
installation Fedora starts with selinux in enforcing mode.

anaconda 11.3.0.50

Comment 1 Jeremy Katz 2008-02-20 23:35:36 UTC
Does this happen with the original Fedora 8 DVD?

Comment 2 Vadym Chepkov 2008-02-23 13:04:35 UTC
Yes, original and Fedora Unity as well.

I digged into it  some more and I think I found where it happens.
It seems anaconda relies on installed system-config-firewall-tui package now. In
my kickstart I had -system-config-firewall-tui in package section. In comps.xml
thos package is not marked as mandatory, but I guess it is, since anaconda
relies on it

Comment 3 Chris Lumens 2008-03-25 17:15:53 UTC
This works for me in rawhide, and anaconda now enforces a requirement on
system-config-firewall-tui.


Note You need to log in before you can comment on or make changes to this bug.