Bug 433231 - xulrunner update ends up with "Error unpacking rpm package..."
Summary: xulrunner update ends up with "Error unpacking rpm package..."
Status: CLOSED DUPLICATE of bug 433096
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-17 22:01 UTC by Michal Jaegermann
Modified: 2018-04-11 14:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 22:31:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2008-02-17 22:01:01 UTC
Description of problem:

More precisely the error is:

Error unpacking rpm package xulrunner-1.9-0.beta3.22.nightly20080215.fc9.x86_64
error: unpacking of archive failed on file
/usr/lib64/xulrunner-1.9pre/dictionaries: cpio: rename

The issue really is that /usr/lib64/xulrunner-1.9pre/directory,
owned by xulrunner-1.9-0.beta2.18.nightly20080210.fc9.x86_64,
inddeed exixts but in xulrunner-1.9-0.beta3.22.nightly20080215.fc9
this is a link to /usr/share/myspell/ (owned by hunspell).
An update attempt leaves a "garbage" link
/usr/lib64/xulrunner-1.9pre/dictionaries;47b86de2
and fails.

That can be recovered by running 'rpm -e --nodeps xulrunner',
cleaning up leftovers and installing the current version.
Is this deemed "we do not care" as earlier distros do not include
xulrunner so no conflict on upgrades will show up?

Version-Release number of selected component (if applicable):
xulrunner-1.9-0.beta3.22.nightly20080215.fc9

Comment 1 Matěj Cepl 2008-02-17 22:31:41 UTC

*** This bug has been marked as a duplicate of 433096 ***


Note You need to log in before you can comment on or make changes to this bug.