Bug 433243 - wrong encoding of backticks -> can't search for `
wrong encoding of backticks -> can't search for `
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Marcela Mašláňová
Fedora Extras Quality Assurance
http://heirloom.sourceforge.net/docto...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 19:15 EST by Mikel Ward
Modified: 2008-04-22 17:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-22 04:53:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikel Ward 2008-02-17 19:15:55 EST
The perlop man page documents the `` (backtick) operator.

When I view this in man, the characters are converted to left single quotes.

Apparently this is the way man pages work (see the URL, plus the groff(7) and
groff_char(7) man pages).

The fix is to replace the ` with \` when it means a ` character.
Comment 1 Mikel Ward 2008-02-17 20:40:31 EST
I have reported this to perlbug@perl.org with the subject "pod2man needs to
translate some ASCII characters".  I don't think I get a bug number or a
confirmation message.
Comment 2 Marcela Mašláňová 2008-02-22 04:53:22 EST
http://rt.perl.org/rt3/Public/Bug/Display.html?id=1865 fixed in perl-5.10
Comment 3 Mikel Ward 2008-02-23 08:26:28 EST
The bug you linked to was closed in 1999 and doesn't seem to address the issue I
raised.  Perhaps you supplied the wrong link?
Comment 4 Tom "spot" Callaway 2008-04-22 11:54:54 EDT
When I run man perlop in F-9 (perl 5.10.0), I see `` (not '') in the "Quotes and
Quote-like Operators" section, so it seems like pod2man is actually working
correctly for this.

Please reopen if you are not seeing this in F-9.
Comment 5 Mikel Ward 2008-04-22 17:41:07 EDT
Cool.  It's nearly done.  There's one line near qx that's still not done correctly.  Was this done 
programmatically or manually?

Ideally it should be done properly by perl2man (or Pod::Man).  There might be other occurrences and 
other pages affected.
Comment 6 Tom "spot" Callaway 2008-04-22 17:48:52 EDT
I don't see any mistakes at all. Can you be very specific as to what you're seeing?

As to how it was fixed, whatever base perl uses to convert the pod file into the
manpage is doing it, not Fedora. :)

Note You need to log in before you can comment on or make changes to this bug.