Bug 433248 - gdm loads, then continuously cycles. can only ctl-alt-del to reboot
gdm loads, then continuously cycles. can only ctl-alt-del to reboot
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-02-17 21:58 EST by Jim Cornette
Modified: 2015-01-14 18:20 EST (History)
2 users (show)

See Also:
Fixed In Version: gdm-2.21.9-2.fc9.i386
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 23:32:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log which shows invisible to user but is visible to root (22.60 KB, text/plain)
2008-02-17 21:58 EST, Jim Cornette
no flags Details
gdm log after removal and reinstallation (22.60 KB, text/plain)
2008-02-18 06:10 EST, Jim Cornette
no flags Details
Attached are ther 5 logs generated in less than a few minutes. (3.97 KB, application/x-gzip)
2008-03-02 18:31 EST, Jim Cornette
no flags Details
This is the final log. (10.70 KB, text/plain)
2008-03-02 18:54 EST, Jim Cornette
no flags Details
Still have the problem - gdm.log attached (27.15 KB, text/plain)
2008-03-07 15:58 EST, Jim Cornette
no flags Details
gdm-binary --debug > /tmp/gdm.log 2>&1 (35.84 KB, text/plain)
2008-03-08 11:16 EST, Jim Cornette
no flags Details
New log with today's rawhide updates applied (94.85 KB, text/plain)
2008-03-10 20:57 EDT, Jim Cornette
no flags Details
New log with koji packages installed (132.14 KB, text/plain)
2008-03-10 21:54 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2008-02-17 21:58:59 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Boot in runlevel 5, see computer screen login followed by constant blanking and
view of login screen for short time. laptop cpu fan kicks on shortly.

Steps to Reproduce:
1.boot into runlevel 5
2. rhgb successful
3.gdm screen loads blanks, reloads
  
Actual results:
I could not change to a vt to get out. I had to hit ctl-alt-del to get out. when
trying to remove gdm it was not cleared by the rpm database. the below files
remain after removal attempt.
 rpm -e gdm
I/O warning : failed to load external entity
"/etc/gconf/schemas/gdm-simple-greeter.schemas"
Failed to open `/etc/gconf/schemas/gdm-simple-greeter.schemas': No such file or
directory
error: %postun(gdm-2.21.7-1.fc9.i386) scriptlet failed, exit status 1
[root@HP-JCF7 ~]# rpm -e gdm --noscripts
[root@HP-JCF7 ~]# updatedb
[root@HP-JCF7 ~]# locate gdm
/etc/gdm
/etc/gdm/custom.conf.livna-config-backup
/usr/lib/deskbar-applet/modules-2.20-compatible/gdmactions.py
/usr/lib/deskbar-applet/modules-2.20-compatible/gdmactions.pyc
/usr/lib/deskbar-applet/modules-2.20-compatible/gdmactions.pyo
/usr/lib/python2.5/site-packages/deskbar/handlers/gdmclient
/usr/lib/python2.5/site-packages/deskbar/handlers/gdmclient/__init__.py
/usr/lib/python2.5/site-packages/deskbar/handlers/gdmclient/__init__.pyc
/usr/lib/python2.5/site-packages/deskbar/handlers/gdmclient/__init__.pyo
/usr/lib/python2.5/site-packages/deskbar/handlers/gdmclient/_gdmclient.so
/usr/lib/python2.5/site-packages/orca/scripts/gdmlogin.py
/usr/lib/python2.5/site-packages/orca/scripts/gdmlogin.pyc
/usr/lib/python2.5/site-packages/orca/scripts/gdmlogin.pyo
/usr/share/gdm
/usr/share/desktop-menu-patches/gnome-gdmsetup.desktop
/usr/share/doc/nss_ldap-257/pam.d/gdm
/usr/share/gdm/themes
/usr/share/gdm/themes/FedoraBubbles
/usr/share/gdm/themes/FedoraDNA
/usr/share/gdm/themes/FedoraFlyingHigh
/usr/share/gdm/themes/FedoraBubbles/background.png
/usr/share/gdm/themes/FedoraBubbles/screenshot.png
/usr/share/gdm/themes/FedoraDNA/background.jpeg
/usr/share/gdm/themes/FedoraDNA/logo.png
/usr/share/gdm/themes/FedoraDNA/screenshot.png
/usr/share/gdm/themes/FedoraFlyingHigh/logo.png
/usr/share/icons/Bluecurve/16x16/apps/gdm.png
/usr/share/icons/Bluecurve/24x24/apps/gdm.png
/usr/share/icons/Bluecurve/32x32/apps/gdm.png
/usr/share/icons/Bluecurve/36x36/apps/gdm.png
/usr/share/icons/Bluecurve/48x48/apps/gdm.png
/usr/share/icons/HighContrastLargePrint/48x48/apps/gdm-setup.png
/usr/share/icons/HighContrastLargePrint/48x48/apps/gdm-xnest.png
/usr/share/icons/HighContrastLargePrint/48x48/apps/gdm.png
/usr/share/icons/HighContrastLargePrintInverse/48x48/apps/gdm-setup.png
/usr/share/icons/HighContrastLargePrintInverse/48x48/apps/gdm-xnest.png
/usr/share/icons/HighContrastLargePrintInverse/48x48/apps/gdm.png
/usr/share/icons/gnome/24x24/apps/gdm.png
/usr/share/icons/gnome/48x48/apps/gdm.png
/usr/share/vim/vim71/syntax/gdmo.vim
/var/gdm
/var/gdm/.cookie
/var/gdm/.fontconfig
/var/gdm/.fontconfig/177aa5f8e4784b879645141d1d73ae7a-x86.cache-2
/var/gdm/.fontconfig/3830d5c3ddfd5cd38a049b759396e72e-x86.cache-2
/var/gdm/.fontconfig/384e8ef016a93c7fa22f842f02c21c89-x86.cache-2
/var/gdm/.fontconfig/49aab29dc58e529ef78a6d0aaa3ba41d-x86.cache-2
/var/gdm/.fontconfig/733eeeb42e62a025a95e737efb697ce3-x86.cache-2
/var/gdm/.fontconfig/7bc9be840852330f6318f25fbc083f28-x86.cache-2
/var/gdm/.fontconfig/7ddba6133ef499da58de5e8c586d3b75-x86.cache-2
/var/gdm/.fontconfig/81c87554abb5cbed44dc91927820b8dc-x86.cache-2
/var/gdm/.fontconfig/ae30b330df83ba0e904b3d2eb05b9c75-x86.cache-2
/var/gdm/.fontconfig/beeeeb3dfe132a8a0633a017c99ce0c0-x86.cache-2
/var/gdm/.fontconfig/d04038e664b0033ae700a78c51f179d3-x86.cache-2
/var/gdm/.fontconfig/d066cc093611c74861a22d5ef60b042c-x86.cache-2
/var/gdm/.fontconfig/e166eff51bb88345c461ae8d1ca7510a-x86.cache-2
/var/gdm/.fontconfig/e5c8a13002b74f260e9f54e1c566d89a-x86.cache-2
/var/gdm/.fontconfig/f4023520196b2bc2c439adcafb2470ff-x86.cache-2
/var/lib/gdm
/var/lib/gdm/.dbus
/var/lib/gdm/.fontconfig
/var/lib/gdm/.gconf
/var/lib/gdm/.gconfd
/var/lib/gdm/.gnome2
/var/lib/gdm/.gnome2_private
/var/lib/gdm/.dbus/session-bus
/var/lib/gdm/.dbus/session-bus/1e0ddc3d95d0a10e00614b0046620fc4-0
/var/lib/gdm/.fontconfig/3830d5c3ddfd5cd38a049b759396e72e-x86.cache-2
/var/lib/gdm/.fontconfig/beeeeb3dfe132a8a0633a017c99ce0c0-x86.cache-2
/var/lib/gdm/.gconf/apps
/var/lib/gdm/.gconf/apps/%gconf.xml
/var/lib/gdm/.gconf/apps/gdm
/var/lib/gdm/.gconf/apps/gdm/%gconf.xml
/var/lib/gdm/.gconf/apps/gdm/simple-greeter
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/%gconf.xml
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins/%gconf.xml
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins/a11y-keyboard
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins/background
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins/xsettings
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins/a11y-keyboard/%gconf.xml
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins/background/%gconf.xml
/var/lib/gdm/.gconf/apps/gdm/simple-greeter/settings-manager-plugins/xsettings/%gconf.xml
/var/lib/gdm/.gconfd/saved_state
/var/lib/gdm/.gnome2/accels
/var/log/gdm
/var/log/gdm/:0.log
/var/spool/mail/gdm


Expected results:
Removal of gdm - when booting up again after yum erase gdm completed, I was
booted into kdm. When I tried to install gdm, it said it was already installed.
When trying to remove it via yum, it replied with the below text.
 gdm                          ######################### [1/1] 
I/O warning : failed to load external entity
"/etc/gconf/schemas/gdm-simple-greeter.schemas"
Failed to open `/etc/gconf/schemas/gdm-simple-greeter.schemas': No such file or
directory

Removed: gdm.i386 1:2.21.7-1.fc9
Complete!


Additional info:
Comment 1 Jim Cornette 2008-02-17 21:58:59 EST
Created attachment 295127 [details]
Log which shows invisible to user but is visible to root
Comment 2 Jim Cornette 2008-02-18 06:10:44 EST
Created attachment 295157 [details]
gdm log after removal and reinstallation

After manually removing /var/log/gdm the /lib/gdm and other gdm related
directories I was able to reinstall gdm again. It still fails the same way.
This log is after a cleanup and re installation of yum.
Comment 3 Jim Cornette 2008-03-02 18:15:34 EST
I'm still having troubles with gdm going briefly to the login screen and
reloading constantly. I tried with the vesa driver and it fails the same as when
the ati driver was working.
Comment 4 Jim Cornette 2008-03-02 18:31:41 EST
Created attachment 296529 [details]
Attached are ther 5 logs generated in less than a few minutes.

This is a ziped file with 5 logs attached. They all looked similar to me.
Comment 5 Jim Cornette 2008-03-02 18:54:19 EST
Created attachment 296530 [details]
This is the final log.

Somehow the zip was made to not work after transfer. The logs pretty much
stated as the sixth of these logs. (0-5)
Comment 6 Jim Cornette 2008-03-07 15:58:59 EST
Created attachment 297249 [details]
Still have the problem - gdm.log attached

Someone mentioned that this problem might be due to the keyboard problem. I
tried after the keyboard problem was somewhat resolved. I am still seeing this
problem with ati or vesa driver.
Comment 7 jmccann 2008-03-07 19:06:04 EST
Can you try logging in remotely, init 3, gdm-binary --debug > /tmp/gdm.log 2>&1

Let it restart a few times.  Then control-C to kill it.  And attach the gdm.log
here.

Thanks.
Comment 8 Jim Cornette 2008-03-08 11:16:47 EST
Created attachment 297308 [details]
gdm-binary --debug > /tmp/gdm.log 2>&1

Attached is the log with the parameters. GDM loaded one time and upon the next
cycle locked up the computer when it respawned. Some corruption to the display
noticeable on the top portion of the screen.
Comment 9 Andrew Farris 2008-03-08 17:28:09 EST
I've had the same symptoms and will try to get that output while it cycles as well.
Comment 10 jmccann 2008-03-10 11:44:27 EDT
Jim, thanks for the log.  Unfortunately, the way we were generating the
backtrace after the crash didn't give us enough information.  In rawhide today
we have a new feature that should give us better debugging information from the
backtrace.  Would you mind repeating your crash and posting a new log after
updating to today's rawhide?
Comment 11 Jim Cornette 2008-03-10 20:53:47 EDT
I am not sure if my version of today's rawhide is up to date. I generated
another log which will be attached after I post this answer.
Comment 12 Jim Cornette 2008-03-10 20:57:34 EDT
Created attachment 297547 [details]
New log with today's rawhide updates applied

Instead of hitting ctl-c to exit I automatically pressed ctl-alt-del after
three reloads of gdm. It started rebooting on the fourth gdm load so it might
not have completed #4
Comment 13 jmccann 2008-03-10 21:15:19 EDT
Jim, can you try the builds here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=42456

If you can try them right away I'd like to try to fix this before the beta
tonight.  If you are on IRC can you msg me (nick "mccann")?  Thanks a lot.  
Comment 14 Jim Cornette 2008-03-10 21:35:38 EDT
I grabbed gdm, gdm-debuginfo and the switch user applet and am installing them
right now. When it finishes installing I will provide the new log with those
versions. Rawhide is awful slow so the install is taking some time to complete.
Comment 15 Jim Cornette 2008-03-10 21:54:33 EDT
Created attachment 297555 [details]
New log with koji packages installed

Here is a log with at least three transitions of a restart. The user seemed to
be visible longer before the reset. Also, the whole display blanked on the last
transition. I hit ctl-c followed by ctl-alt-del since no display was active on
last transaction.
Comment 16 jmccann 2008-03-10 22:28:29 EDT
OK!  I think I've fixed this.  It is building now for rawhide:
http://koji.fedoraproject.org/koji/taskinfo?taskID=509838

Thanks a lot for responding so quickly.  It was a big help.
Comment 17 Jim Cornette 2008-03-10 22:37:46 EDT
No problem. If it helps I have no problem assisting with  information.
Comment 18 jmccann 2008-03-11 14:14:03 EDT
Jim, can you verify that today's update fixes your problem?
Comment 19 Jim Cornette 2008-03-11 18:10:30 EDT
I'll report back once the updates all get installed. With 140 plus updates it
might be in a few hours.
Comment 20 Andrew Farris 2008-03-11 18:24:18 EDT
This did fix my gdm respawning issue.  I'm able to run gdm and login now rather than working through 
startx.
Comment 21 Jim Cornette 2008-03-11 19:21:33 EDT
This sounds promising. I'm still applying updates. Will still confirm once the
updates finish.
Thanks for testing and reporting back.
Comment 22 Jim Cornette 2008-03-11 23:32:36 EDT
Confirming a successful login. Whatever was changed seemed to resolve the problem.

Note You need to log in before you can comment on or make changes to this bug.